PLL Clock change issue on MQX 3.8.1

cancel
Showing results for 
Search instead for 
Did you mean: 

PLL Clock change issue on MQX 3.8.1

Jump to solution
264 Views
lucianomoretti
Contributor IV

I've got a K70 based MQX 3.8.1 project I've inherited, and I need to change the DDR frequency to 150Mhz from the bsp default of 120Mhz.  I've changed the bsp_cm.h file from:

#define CPU_PLL_FLL_CLK_HZ_CONFIG_0    120000000UL

to

#define CPU_PLL_FLL_CLK_HZ_CONFIG_0    150000000UL

I've verified that my BSP's .a file is being updated, and even gone so far as to printf the value of CPU_PLL_FLL_CLK_HZ_CONFIG_0 from my application code, but the O-scope still says my PLL is at 120Mhz.  The above change worked in my MQX 4.1.1 projects, and I can't figure out why it hasn't had the same effect in my MQX 3.8.1 project.

Tags (2)
0 Kudos
1 Solution
82 Views
lucianomoretti
Contributor IV

Thank you.  This helped immensely.  It looks like the PRDIV1 register was set up differently in the BSPs, and the #define didn't actually do anything. Going back to older 4.1.1 builds the DDR is clocked at 150mhz.

Now to work with my EE to verify all the settings to verify that all the peripherals are clocked correctly.

View solution in original post

0 Kudos
2 Replies
82 Views
soledad
NXP Employee
NXP Employee

Hello Luciano,

Please check the attached document, this document shows how to change default clock settings in Kinetis BSPs.

I hope this helps!!


Have a great day,
Sol

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
83 Views
lucianomoretti
Contributor IV

Thank you.  This helped immensely.  It looks like the PRDIV1 register was set up differently in the BSPs, and the #define didn't actually do anything. Going back to older 4.1.1 builds the DDR is clocked at 150mhz.

Now to work with my EE to verify all the settings to verify that all the peripherals are clocked correctly.

View solution in original post

0 Kudos