MQX - RTCS

cancel
Showing results for 
Search instead for 
Did you mean: 

MQX - RTCS

119 Views
Contributor III

Hi Guys,

I am using keil IDE and mqx 4.1. The board I am using is twr-k70f120m.

I wanted to use snmp httpserv and serial to eth in same project.

So this is how I wanted.

There will be three options displayed in the uart and if the user selects any one among the three that should start and if the user selects the other option the other should start, stopping the already running one.

1) Webpage (httpsrv example)

2) snmp (snmp example)

3) tcp (eth to serial)

I tried to integrate these into one project.

So far I am able to integrate snmp and webpage. But the issue is if I select webpage first it is working fine. If I select snmp then webpage stops and snmp starts working. But the issue is when I select 1 again the webpage is not starting again 

It is displaying IPCFG: Device n.0 init failed. Error = 0x10419 error.

The same happens if I select snmp the second time. It is displaying Failed to initialize SNMP agent, error = 1140 error.

I tried using 

ipcfg_release_device(phy_addr);

when I select snmp to try to release the device which is initialized but it is not working.

How should I do it?

Please help

Regards,

Vibhu

0 Kudos
1 Reply

8 Views
NXP TechSupport
NXP TechSupport

Hi Vibhu

In your project, when you select webpage, RTCS start starts.  Next, when you select snmp, you need to reinitialize RTCS, including release all RTCS memory. and restart RTCS stack again.

Unfortunately, this is not a normal behavior for embedded system.  and MQX RTCS was not designed for this.

One possible way is to restart the system when you change your option. Then RTCS can reinitialize again.

Regards

Daniel

0 Kudos