MQX 4.1.1 I2C Driver

cancel
Showing results for 
Search instead for 
Did you mean: 

MQX 4.1.1 I2C Driver

Jump to solution
229 Views
josephchen
Contributor III

I'm using MQX 4.1.1 and working on I2C example. When I use I2C interrupt, it's calling the low level driver functions in i2c_int_ki2c_legacy.c file. If I try to replace with i2c_int_ki2c.c file, there're will be some macros undefined, for example I2C_FLT_SSIE_MASK in the line 129, and some others. I wonder if there's anyone using the one which is not legacy in MQX 4.1.1.

1 Solution
96 Views
danielchen
NXP TechSupport
NXP TechSupport

Hi Joseph:

Please check the i2c driver for bsp_twrk64f120m,  it uses i2c_int_ki2c.c file, not i2c_ki2c_legacy.c


Have a great day,
Daniel

View solution in original post

0 Kudos
1 Reply
97 Views
danielchen
NXP TechSupport
NXP TechSupport

Hi Joseph:

Please check the i2c driver for bsp_twrk64f120m,  it uses i2c_int_ki2c.c file, not i2c_ki2c_legacy.c


Have a great day,
Daniel

View solution in original post

0 Kudos