ICMP (ping) is unstable at TWRK60-KIT

cancel
Showing results for 
Search instead for 
Did you mean: 

ICMP (ping) is unstable at TWRK60-KIT

Jump to solution
570 Views
MortenKvistgaar
Contributor I

Hello there,

 

I've just bought a TWRK60-KIT and have worked my way through the 'Getting Started'.

 

The MQX and TCPIP seems to be working. At least most of the time. My first test with any ethernet hw is always a simple 'ping' from the PC... and that one is extremely unstable!!! Every 10th ping fails! (It's not consistent.)

 

I'm using the newest CW with updates and the newest MQX. I've sat the jumpers on the TWRK60-KIT as specified in the 'Getting Started'. 

I've just created a new CW MQX project, in which I've only added the TCP stack. Am I missing something?

 

The ICMP service is not that important in it self. But unstable TCP in general is uacceptable. And the rest of my ethernet setup is fine. The PIC32 I have next to the TWRK60-KIT isn't missing any pings.

 

Debug/Release config makes no difference. DHCP/Static neither.

Labels (1)
Tags (1)
0 Kudos
1 Solution
154 Views
petr_uhlir
NXP Employee
NXP Employee

Hello Morten,

check your jumper settings. To enable Ethernet communication with TWR-SER board you have to set: 

 

TWR-K60N512 board

o Jumper J6 on position 2-3  (Processor clock taken from the TWRSER board.)

You have it probably wrong and clock are taken from processor board - J6 on position 1-2. This causes wrong ethernet communication, lost packets as clocks in processor and PHY are not synchronous. 

 

TWR-SER board

o CLK_SEL 3-4

o CLKIN-SEL 2-3 (processor clock is taken from PHY)
o TWR-SER - ETH-CONFIG J12 9-10 to select RMII communication mode

View solution in original post

0 Kudos
2 Replies
155 Views
petr_uhlir
NXP Employee
NXP Employee

Hello Morten,

check your jumper settings. To enable Ethernet communication with TWR-SER board you have to set: 

 

TWR-K60N512 board

o Jumper J6 on position 2-3  (Processor clock taken from the TWRSER board.)

You have it probably wrong and clock are taken from processor board - J6 on position 1-2. This causes wrong ethernet communication, lost packets as clocks in processor and PHY are not synchronous. 

 

TWR-SER board

o CLK_SEL 3-4

o CLKIN-SEL 2-3 (processor clock is taken from PHY)
o TWR-SER - ETH-CONFIG J12 9-10 to select RMII communication mode

0 Kudos
154 Views
MortenKvistgaar
Contributor I

I had missed the J6 jumper on the TWR-K60N512 board.

 

Thank you.

0 Kudos