how to disable Nexus Function

cancel
Showing results for 
Search instead for 
Did you mean: 

how to disable Nexus Function

Jump to solution
117 Views
NXP Employee
NXP Employee

Hi,

5744P, Nexus related pad muxed to GPIO. when enter debugging mode via JATG , the GPIO seems do not controlled by SW. when dis-connect debugger, the GPIO work well in GPIO mode. 

Could you please check, if entering debugging mode through JATG, Nexus even be started, and then Nexus related working on Nexus IO.

And how to disable nexus .

below is JTAG circuit please check it.

pastedImage_2.png

0 Kudos
1 Solution
28 Views
NXP Employee
NXP Employee

Hi Lukas,

With help from Lauder Bach,  we successfully disable Nexus by TrOnchip.EVENT OFF cmmand.

thanks for your help.

View solution in original post

0 Kudos
6 Replies
29 Views
NXP Employee
NXP Employee

Hi Lukas,

With help from Lauder Bach,  we successfully disable Nexus by TrOnchip.EVENT OFF cmmand.

thanks for your help.

View solution in original post

0 Kudos
28 Views
NXP Employee
NXP Employee

Hi Lukas,

Thanks for your prompt reply

used this GPIO 91(NPC_WRAPPER_EVTI_ON)

pastedImage_1.png

0 Kudos
28 Views
NXP TechSupport
NXP TechSupport

Hi Alvin,

use this command to turn off the EVTI signal - it's ON by default:

pastedImage_1.png

Then you can use the pin as GPIO also in debug mode.

Do you need to such configuration also for Pemicro? I didn't find it, I would have to ask others. Just let me know...

Regards,

Lukas

0 Kudos
28 Views
NXP Employee
NXP Employee

Hi Lukas,

customer used Lauderbach via JATG, i duplicated the issue w/ PE-Multi-link via JATG on 5744P EVB, from SSCM Status register, here i see NXEN bit is 1, means Nexus enabled.

Please confirmed that. TKS

pastedImage_1.png

0 Kudos
28 Views
NXP TechSupport
NXP TechSupport

Hi Alvin,

I did quick test on my board using Lauterbach and PE Multilink Universal FX.

I used signal NEXUS_MSEO0_B (GPIO 89) which is easily accessible on Nexus P1 connector on EVB.

I'm toggling this pin in endless loop in my project.

In Lauterbach, I simply use 'sys.up', no other configuration is done. I can toggle the GPIO when debugger is connected. Then I used command Nexus.ON (it's OFF by default) and I can't toggle the pin now. Then I used Nexus.OFF and I can toggle the pin again.

pastedImage_1.png

When I'm using PE Multilink, I can toggle the pin too. There's no trace option, so there's no configuration I could test.

Notice that NXEN bit in SSCM is something different. It only says, if debug mode is entered or not. If a debugger is connected, it's '1'. If not, it's '0'.

From my point of view, this is expected behavior. Which pins do you use exactly?

Regards,

Lukas

0 Kudos
28 Views
NXP TechSupport
NXP TechSupport

Hi Alvin,

the device always starts up in JTAG mode and the Nexus must be explicitly enabled via JTAG if needed. So, the question is what kind of debugging tools you use.

JTAG signals seems to be correct  in the picture.

Regards,

Lukas

0 Kudos