The GDB Server was not able to establish a connection to the target processor.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

The GDB Server was not able to establish a connection to the target processor.

Jump to solution
1,234 Views
baenux
Contributor II

Hi.

I am using the MPC5775B based RDVCU5775EVM board.

The following error occurred while processing step '13 Download to the MCU' of 'Projects and Tutorials'.

https://www.nxp.com/document/guide/get-started-with-the-mpc5775b-bms-and-vcu-reference-design:GS-RDV... >

 

화면 캡처 2023-04-25 124224.png

error message

Error in services launch sequence
The GDB Server was not able to establish a connection to the target processor. Please check your connections and power. Verify that the launch settings in the Debug Configuration are accurate. To run simultaneous debug sessions, please specify a unique Server Port and GDBMI Port

 

Please tell me how to solve the error.

 

My details are as follows.
 
OS : Window10
IDE : S32 Design Studio for Power Architecture 2017.R1
SDK :  { IDE>Help>Install new software> } Update 11 SDK PA RTM 3.0.0

Debugger : P&E Multilink Universal

There was a code inside when I purchased the product, and I am currently trying to put the same code.

 

baenux_0-1682395304422.png

baenux_1-1682395334910.png

baenux_2-1682395357695.png

 

Could we get help?

Thanks

Tags (1)
0 Kudos
1 Solution
1,222 Views
davidtosenovjan
NXP TechSupport
NXP TechSupport

Have you ever get it to run or the issue happens with first time usage?

View solution in original post

0 Kudos
5 Replies
1,184 Views
nawoc70910
Contributor I

Error in the services launch sequence. PEmicro GDB Launch Failure: The GDB Server was not able to establish a connection to the target processor. Icd 10 Code for Colovesical Fistula

0 Kudos
1,223 Views
davidtosenovjan
NXP TechSupport
NXP TechSupport

Have you ever get it to run or the issue happens with first time usage?

0 Kudos
1,217 Views
baenux
Contributor II

When I first received the product, the code was already inside.
At that time, the product worked normally.

However, I planned to change some of the code and apply it, so I tried to put the original code as a test, but it failed.

0 Kudos
1,198 Views
davidtosenovjan
NXP TechSupport
NXP TechSupport

Please check LEDs, jumpers and power supplies marked by red below:

davidtosenovjan_0-1682664227455.png

 

0 Kudos
1,177 Views
baenux
Contributor II

The problem has been resolved.

Resolved by setting the workspace directory to its default location.

I'm not sure why, but when I set the workspace location to C:\Users\<username>\workspaceS32DS.Power.2017.R1, the above issue was resolved.

Thank you for your continued support.

0 Kudos