MPC5744P Rev. E1 - Code Execution Issue with MBDT or S32

cancel
Showing results for 
Search instead for 
Did you mean: 

MPC5744P Rev. E1 - Code Execution Issue with MBDT or S32

348 Views
hbhnhbnhj1
Contributor III

Hi there, 

I bought 6 pieces of MPC5744P (Rev. E1) and DEVKIT-COMM (Rev. A) at this year.

hbhnhbnhj1_5-1644489150719.png


I tested different code to verify the functionality of each board, the testing condition is as follow,
【S32 v2.1 / MBDT v3.2 / Matlab R2018a / Windows 10 / ASUS G1401I】

The testing result and question is described as follow.
( to prevent misunderstanding, 6 piece of MPC5744P is numbering as A, B, C, D, E, F ) 

1.
two out of six board cannot execute the code from MBDT.

hbhnhbnhj1_3-1644488591551.png

I have seen the post discussed the issue of oscillator of clock source, link of post is as below.
MPC5744p RevE MBD flash problem - NXP Community

Therefore, I guess the external clock of two board (A, B) in the above table is malfunction.
If the guess above is true, can I have the return or exchange? @mariuslucianand

2.
four out of four (C, D, E, F) board cannot execute the 【LED & UART】of 【flexcan_master_mpc574x】from MBDT.

hbhnhbnhj1_4-1644488614423.png

*Is the code to initialize the LED not for Rev.E?
 (I found this issue from Solved: Re: DEVKIT-MPC5744P CAN testing - NXP Community )
*Is the code to initialize the UART wrong? 
@PetrS  @mariuslucianand  @constantinrazva  @raresvasile @adriantudor

If there is any other information needed, please let me know, thanks for your help!

 

 

 

Tags (4)
0 Kudos
4 Replies

309 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

I can comment FlexCAN_MPC5744P demo in S32DS.
After doing modification mentioned in  Solved: Re: DEVKIT-MPC5744P CAN testing - NXP Community I am able to see terminal message and communicate with CAN tool on rev.E board

PetrS_1-1644579105826.png

No message is send from PC, but receiving on MCU is successful because self reception is enabled MCR[SRXDIS]=0) and RX MB is configured to receive same ID that is send.

Not sure why code for LED control is done that way. But you can easily modify it. Use below code to enable output on PC11

SIUL2.MSCR[PC11].B.OBE = 1; // enable output buffer on PC11, driving red LED

then output level can be controlled by

SIUL2.GPDO[PC11].R = 0; // Turn on red LED
SIUL2.GPDO[PC11].R = 1; // Turn off red LED
SIUL2.GPDO[PC11].R ^= 1; // Toggle red LED

BR, Petr

 

0 Kudos

170 Views
hbhnhbnhj1
Contributor III

Hi @PetrS , thanks for your reply and sorry for my delayed response.

I still cannot receive 0x555 from CAN listener ( Komodo CAN Duo ), 
but the red led is on. 

My board version is revE1 as shown in figure below.

oiufego.jpg

I have modified the code as specified in  Solved: Re: DEVKIT-MPC5744P CAN testing - NXP Community as shown in figure below.

螢幕擷取畫面 2022-04-19 115721.png

螢幕擷取畫面 2022-04-19 115755.png

 My CAN connection is as figure below, CAN0 - CAN2 - CAN listener

hbhnhbnhj1_2-1650341545282.jpeg

However, if I also change the LOOPBACK to 0.
hbhnhbnhj1_0-1650343172882.png
1. the CAN listener can get 0x555
2. the red led is vanished
3. the UART still got nothing

Also, what is the meaning of DS and MB shown in the comment at main.c

hbhnhbnhj1_1-1650343317894.png


By the way, @adriantudor 
the UART should print the data received if the description is right as shown in figure below.

hbhnhbnhj1_3-1650341858089.png

hbhnhbnhj1_4-1650341860565.png

However, there is no data shown in UART terminal.
The jumper configuration is shown as figure below and the code is as attached.

hbhnhbnhj1_6-1650342211512.jpeg

Please help me solve these issues, thank you!

 





 

Tags (3)
0 Kudos

315 Views
adriantudor
NXP Employee
NXP Employee

Hello @hbhnhbnhj1

For the second point:

Have you updated the model with the right pin configurations for your board version? If you have done that, please send us your models and a picture with jumpers configurations. As far as I know, the default model "flexcan_master_mpc574x" doesn't use any UART block. Can you send us this model or give us more detail ?

 

Best regards,

Adrian

 

0 Kudos

169 Views
hbhnhbnhj1
Contributor III

Hi @adriantudor,

Thanks for your reply and sorry for my late response.

The feedback is described in the reply to @PetrS
Re: MPC5744P Rev. E1 - Code Execution Issue with M... - NXP Community
please refer to it, thank you.

0 Kudos