MPC5743R SIUL2

cancel
Showing results for 
Search instead for 
Did you mean: 

MPC5743R SIUL2

1,452 Views
ypchen
Contributor III

hi,I'm debugging SPC5743R EVB with S32DS v1.0 and PE Multlink.

I can not access the SIUL2 Registers (Address:0xFFFC0000~0xFFFC3FFF).why?

Regards

Labels (1)
0 Kudos
5 Replies

804 Views
martin_kovar
NXP Employee
NXP Employee

Hi,

what do you mean you cannot access the SIUL2 registers? In the picture you share, I see the values in the registers. Could you please clarify your issue?

Regards,
Martin

0 Kudos

804 Views
ypchen
Contributor III

Hi,

In the picture,the values in the SIUL2 registers only are " register's Address".Also,I cannot access some other Peripheral 's registers,like FlexCAN、DSPI ..

Regards

0 Kudos

804 Views
martin_kovar
NXP Employee
NXP Employee

Hi,

I am sorry I have overlooked the value in the field. And what you see, if you expand the register? Do you see correct values or nonsense?

I tried the reproduce your use case (the same microcontroller, Design Studio and also debug probe, default project), but this is what I see.

pastedImage_1.png

I think the best way is to download newest S32 Design Studio (version 1.1) and install the update 1. Many bugs are fixed in the newest version, please consider it.

S32 Design Studio for Power Architecture v1.1 (Windows, Linux) released! 

https://community.nxp.com/docs/DOC-333045 

Regards,

Martin

0 Kudos

804 Views
ypchen
Contributor III

hi

In the EVB,the MCU is marked "PPC5743RDMLQ5 0N83M QAE1429A",and ,I can not access the SIUL2 Registers .

I changed this MCU with a new one,which marked "SPC5743RMLQ5 QHV1628 1N83M EUAMQD",then,I can access these Registers successfully.

Another problem:I created a .elf,which can TX data with UART(LINFLEX_1).I download the .elf to the two MCU,but,the Baud rate is different,why ?

Regards

0 Kudos

804 Views
martin_kovar
NXP Employee
NXP Employee

Hi,

unfortunately I have only cut 2.0b (mask 1N83M), so I am not able to try the older cut, but I will try to ask my colleague about S32 Design Studio debugger.

About UART settings, please check, if the dividers and frequencies are the same on both microcontrollers. It is possible, there are some changes between the cuts.

Regards,

Martin