MPC5645S DCU3 - 16BIT Colour problem

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MPC5645S DCU3 - 16BIT Colour problem

470 Views
peteradamcik
Contributor III

Hi Guys, HAPPY NEW YEAR

I've setup the DCU3 to 640x480x16bit colour mode. Thats 5-6-5 colour (5 red, 6 green, 5 blue). I've connected my homemade resistor DAC to a LCD TV and its working fine.

The problem I am having is that on displaying certain colours on the screen theres a dark shade after a  specific pixel colour and I have no idea what is causing it. All the other colours are fine but its just a few colours that has the darker shade pixel to the right of that pixel. I have not tested 24bit colour mode yet just the 16bit 5-6-5 colour mode.

I have attached a picture of a colour test I did and you can see after a few colours there is a dark pixel next to it. Thats the dark colour pixel I'm telling you about. I draw up some graphics on the screen and depending on the colours I use the darker pixel is on the screen and makes my graphics look terrible.

Please see the attached photo and if you have any ideas why this is happening please let me know. 

Thanks and HAPPY NEW YEAR. 

Pete. 

0 Kudos
3 Replies

398 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi Peter,

have you got any better result with displaying your graphics, e.g with testing other color modes? 
I do not fully get the connection with LCD TV, could that be source of possible issue, or you are sure you made it well.

BR, Petr

0 Kudos

392 Views
peteradamcik
Contributor III

Hi Petr, no still the same fault. I have tried 24bit colour mode and still the same fault with the colour. Can I send you a private message to discuss this further?

Peter 

 

0 Kudos

385 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi, 

lets try, will see if can help anyhow. But this looks very specific application fault.

BR, Petr

0 Kudos