MPC5634M BAM pin129

cancel
Showing results for 
Search instead for 
Did you mean: 

MPC5634M BAM pin129

268 Views
NXP Employee
NXP Employee

Dear Support Team:

 

My customer is using MPC5634M BAM module to load their application code into internal flash through CAN bus. Pin129 is used as a GPIO drive some external circuit with a pull-down resistor to ground.

 

So far everything works fine if the pull-down resistor is 100K Ohm.
However we could not connect to the micro if the pull-down resistor is changed to 10K Ohm.

 

Since pin129 is multiplexed with NEXUS EVTO function, we are not sure if there is any conflict. And according to datasheet, this function is not available on 176LQFP package.

 

Could you help to check if extra attention should be paid here?
Your quick response would be highly appreciated!

 

Best Regards,
Wang.

Labels (1)
0 Kudos
8 Replies

13 Views
NXP TechSupport
NXP TechSupport

Hi,

first of all, what is connected to SCI_A_RX pin?

pastedImage_1.png

pastedImage_3.png

pastedImage_2.png

If there's a noise on that pin, it could be the root cause.

I can't see difference between 10k-100k resistance on EVTO, so let's check other things first...

Regards,

Lukas

0 Kudos

13 Views
Contributor II

Why is my application not running, and I'm going to set it up in the bam mode in your way.Are all the starting addresses the same?

0 Kudos

13 Views
NXP TechSupport
NXP TechSupport

Hi,

have you followed this comment?

https://community.nxp.com/thread/320166#comment-384300

Especially: "The RAM.mot cannot be downloaded by BAM directly. It must be continuous image without gaps. You can either write some program on PC that will create continuous binary file or you can download the project into RAM by debugger, then save the content of RAM memory to binary file. "

Regards,

Lukas

0 Kudos

13 Views
NXP Employee
NXP Employee

Hi Lucas:

How are you doing? Thank you for your help again. :smileyhappy:

In the application, SCI_A_RX is always pulled up to 5V through 10K Ohm. And everything works fine when pull-down to pin129 is 100K Ohm...

Would you help to check if any special config should be taken here?

Thanks and Best Regards,

Wang.

0 Kudos

13 Views
NXP TechSupport
NXP TechSupport

Hi Wang,

do you use auto baud rate detection or not?

EVTO pin is used to disable or enable this feature:

pastedImage_1.png

There's internal pull up on this pin. If you use external 100K pull down, then this pull down is not strong enough to override the internal pull up. So, there will be logic '1' and the auto baud rate detection is disabled.

If you use 10K pull down, it will override the internal pull up, so auto baud rate detection will be enabled.

I think that this could be the reason.

Regards,

Lukas

0 Kudos

13 Views
NXP Employee
NXP Employee

hi Lukas:

Actually the question is, according to datasheet, EVTO function is not available on 176LQFP package...

Could you help to double check?

Best Regards,

Wang.

0 Kudos

13 Views
NXP TechSupport
NXP TechSupport

Even if EVTO function is not available, the pin is still there. I did quick test on my 144pin package and when I add pull up or pull down to this pin, I can see that SIU_RSR[ABR] is changed as expected.

Regards,

Lukas

0 Kudos

13 Views
NXP Employee
NXP Employee

hi Lukas:

Got it and thank you!

Best Regards,

Wang.

0 Kudos