How to solve the problem of SecondCore not being able to start in multi-core engineering

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to solve the problem of SecondCore not being able to start in multi-core engineering

Jump to solution
554 Views
wangjain
Contributor II

I am using the sample project [MPC574XG-MCAL4_0-RTM_1_0_5_Sample_Application] with the compiler GHS and the command [./launch. bat OS TOOLCHAIN=ghs]

】Compilation passed. Multi cores are configured in the EB project, and the generated code is also replaced in the subdirectory [cfg] of [MPC574XG_MCAL4_0_RTM_1_0_5_Sample_Application]. In addition, the function StartCore (OS_SECOND_CORE,&setValue) is called in the main function to start the slave core. It can also be compiled and passed. However, after burning the generated elf file into [DEVKIT-MPC5748G] and stepping into the function StartCore, it was found that the slave core did not start. May I ask how to solve this problem? Thank you.

0 Kudos
1 Solution
476 Views
wangjain
Contributor II
Hi,Peter
I have debugged it again, and the multi-core can now start. thank you very much.

View solution in original post

0 Kudos
4 Replies
523 Views
petervlna
NXP TechSupport
NXP TechSupport

Hello,

To start the core you need 3 simple steps.

1. set start address

2. enable core in desired RUN mode

3. do mode transition.

I expect you are not calling mode transition after you enable cores as if I remember correctly mode translation is separate function.

This is all you need, make sure your MCAL SW is doing that:

petervlna_0-1681199242867.png

Best regards,

Peter

0 Kudos
515 Views
wangjain
Contributor II
Hi,Peter
Following the three steps provided, I attempted to modify the software, but still couldn't successfully start multi-core. Can you provide a multi-core project based on MCAL+OS.

Thank you very much.

Best regards,
wangjain
0 Kudos
506 Views
petervlna
NXP TechSupport
NXP TechSupport

Hello,

Hmm, did you verify if the registers are updated in your project according to the sample code I have shared?

Furthermore I will ask if there is an MCAL+OS multicore example available.

Best regards,

Peter

0 Kudos
477 Views
wangjain
Contributor II
Hi,Peter
I have debugged it again, and the multi-core can now start. thank you very much.
0 Kudos