DMA on MPC5744P with uC RTOS

cancel
Showing results for 
Search instead for 
Did you mean: 

DMA on MPC5744P with uC RTOS

645 Views
embedded_eng
Contributor I

Hello,

 

can anyone help me with UART - DMA Tx on Freescale MPC5744P. Im using Micrium uCOSIII Operating system, and DMA_Tx_Init is in one of the tasks (before while loop).

When i'm using DMA for UART Tx without OS it works great, but when uCOS is involved, DMA isn't triggering.

 

I suppose there are some flaws in my code involving interrupts, but i can't find any bugs.

 

Are there any known issues with uCOSIII involving DMA and/or interrupts?

Also, i'm not sure, if there are any special interrupt or int_vector i should enable or set?

 

Thank you.

0 Kudos
3 Replies

373 Views
xuxungao
Contributor II

hello, lv Brl, i'm trying to use ucos with MPC5744P, but failed. could you please share me some demo code on 5744, thank you.

0 Kudos

373 Views
yuanqingdong
Contributor I

hi  , lv Brl ,i  am try to use ucos ii  to mpc5744p  . but failed .can you give me a demo for ucos ii on mpc5744 ,thank you .

 

0 Kudos

373 Views
martin_kovar
NXP Employee
NXP Employee

Hello Ivan,

Micrium uCOSIII Operating system is not NXP product, so I recommend you to contact Micrium support directly.

You write you tried UART with DMA without operating system and it had worked correct (I also tested this feature and I can confirm it works correct), so from my point of view, there could be some error within the operating system.

Please see the link below and contact Micrium support.

Maintenance Plan | Micrium 

Regards,

Martin

0 Kudos