【5604B】<eMIOS configure> 12 input capture channels (with RAppiD file APS5604B.rsp.zip)

cancel
Showing results for 
Search instead for 
Did you mean: 

【5604B】<eMIOS configure> 12 input capture channels (with RAppiD file APS5604B.rsp.zip)

Jump to solution
174 Views
kl0127
Contributor I

I used RAppiD to configure 5604B 

I want 12 input capture channels  to receive signal 

 

But I got 12 error after I configure  settings

pastedImage_2.jpg

I have no idea how to solve " counter bus B are not done in channel 0 "

 

Dose It mean that  I can't use 12 input  capture channels ?

Thank you very much !

1 Solution
38 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

I am not familer with RAppID, but probably you selected local counter bus (BSL=1) for individual eMIOS channels and channels that serve counter bus B (ch0), C(ch8) and D(ch16) do not enable prescaler and are not set for MCB mode.

Try to select counter bus A (BSL=0) for individual input channels and confige ch23 to serve counter bus A, set it for MCB mode.

BR, Petr

View solution in original post

2 Replies
38 Views
kl0127
Contributor I

Thank you petr !!

I solved the problem.  SAIC have select  counter BuspastedImage_1.png

I can't use channel 23 (serve counter bus A (ch23)) . 

Ch23 have to set  for Modulus Counter (counter Bus [A]).

pastedImage_2.png

Next, all of the SAIC channel  select  counter Bus [A].

BR, Kevin 

0 Kudos
39 Views
PetrS
NXP TechSupport
NXP TechSupport

Hi,

I am not familer with RAppID, but probably you selected local counter bus (BSL=1) for individual eMIOS channels and channels that serve counter bus B (ch0), C(ch8) and D(ch16) do not enable prescaler and are not set for MCB mode.

Try to select counter bus A (BSL=0) for individual input channels and confige ch23 to serve counter bus A, set it for MCB mode.

BR, Petr

View solution in original post