MCUXpresso Secure Provisioning Tool V3.0: failing "Authenticated (HAB)" image build

cancel
Showing results for 
Search instead for 
Did you mean: 

MCUXpresso Secure Provisioning Tool V3.0: failing "Authenticated (HAB)" image build

Jump to solution
28 Views
embeddedev
Contributor I

Hello,

I'm trying to build "Authenticated (HAB)" image for MIMXRT1064, using MCUXpresso Secure Provisioning tool version 3.0, but I get following error. I'm using the images for EVK boards
provided by the tool in the data\targets\MIMXRT10##\source_images\ sub-folder. Keys and certificates from "Keys Management" tab are generated ok.

"Unsigned" and "XIP Encrypted (BEE User Keys) Unsigned" images are building fine.

Do you have any idea what could be wrong?


Thank you.

-----------------
elftosb -f imx -V -c "C:\(...)\secure_provisioning21\bd_files\imx_application_gen_win.bd" -o "C:\(...)\secure_provisioning21\bootable_images\evkmimxrt1064_iled_blinky_int_RAM.bin" "D:\(...)\MCUX_Provi_v3\bin\data\targets\MIMXRT1064\source_images\evkmimxrt1064_iled_blinky_int_RAM.s19"
error: line 11: syntax error
Undefined error
Section: 0x14
Section: 0x15
Section: 0x16
Section: 0x18
Section: 0x19
Section: 0x1a
Section: 0x1f
Section: 0x21
error: failed to run code signing tool
elftosb failed
-----------------

0 Kudos
1 Solution
22 Views
liborukropec
NXP Employee
NXP Employee

Hello,

 

make sure that the SPT installation and SPT workspace are on the same drive. Either both on C:\ or both on D:\. There's such limitation of windows unfortunately.

 

Regards,

Libor

View solution in original post

0 Kudos
2 Replies
23 Views
liborukropec
NXP Employee
NXP Employee

Hello,

 

make sure that the SPT installation and SPT workspace are on the same drive. Either both on C:\ or both on D:\. There's such limitation of windows unfortunately.

 

Regards,

Libor

View solution in original post

0 Kudos
20 Views
embeddedev
Contributor I

Installing on same drive fixed my problem and now all Boot Types are building fine. Thank you! 

0 Kudos