MCU-Link PRO UART communication with RT1060 EVKB

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MCU-Link PRO UART communication with RT1060 EVKB

2,260 Views
keith1
Contributor I

We are planning on using the MCUXpresso Secure Provisioning Tool for production with the MCU-Link PRO board.

We've been testing this set up using our RT1060 EVKB by isolating the built in programming MCU.

However the UART test in the tool always fails.

We have analysed the UART lines from both boards and they look identical in terms of their 0s & 1s.

Is there something missing from the provisioning tool?

0 Kudos
Reply
8 Replies

1,792 Views
david_piskula
NXP Employee
NXP Employee

Hello @keith1,

if this issue is still relevant for you, I was able to run a successful UART test with the isolated LPC and with MCU Link Pro:

david_piskula_0-1679559223270.png

 

I don't have an RT1060-EVKB but I have tried it on an RT1060-EVK. The UART behavior should be identical, just the layout of the board is a bit different and the jumpers have different numbering.

I removed the UART, SWD and JTAG jumpers, same as you. I connected the purple wire from MCU Link (VCOM IN) to UART1_TXD and the grey wire (VCOM OUT) to UART1_RXD. 

I have a hello world example running on the board with the terminal echo functionality (whatever you type in the serial terminal gets echoed by the device) and when using internal boot, I can talk to the device over a COM port. When using SDP mode, I can do the successful test in the Secure Provisioning tool.

One thing I noticed is that sometimes when I reset the EVK while the UART wires from MCU Link are connected to the pins on the EVK, the device doesn't boot properly. I recommend you first remove the jumpers, set the boot pins to SDP, reset the board and as the last step, connect the UART wires. This way it's worked smoothly for me.

Let me know if you need any more info.

Best Regards,

David

0 Kudos
Reply

2,237 Views
marek-trmac
NXP Employee
NXP Employee

Dear keith1.

UART for RT1060 was tested in MCUXpresso Secure Provisioning Tool tool, however we did not use MCU Link Pro for UART connection.

Regards,
Marek
0 Kudos
Reply

2,233 Views
keith1
Contributor I

Hello Marek,

Would it be possible for you to test using the new MCU-Link PRO with the Secure Provisioning Tool.

What have you tested the MCU-Link PRO with?

For your information we've been unable to get USB to work as a serial downloader due to the Secure Provisioning Tool having fixed VID & PID addresses.

For production we'll want to to use the secure provisioning tool as there's a requirement for using secured boot.

0 Kudos
Reply

2,226 Views
liborukropec
NXP Employee
NXP Employee

Hello Keith,

if you use EVKB and external MCU Link Pro. Could you provide the information about EVKB jumpers settings (changes) and/or wiring. It might have an influence on the functionality.

 

Thank you,

Libor

0 Kudos
Reply

2,223 Views
keith1
Contributor I

Hello,

We isolated the on-board LPC4322JET100 interface MCU on the RT1060 EVKB by removing jumpers J3, J4, J9, J10, J11 & J13.

J3 & J4 are JTAG, J9 & J10 are SWD & J11 & J13 are UART. Each jumper has the interface processor on pin 1 with the main RT1062 processor on pin 2.

We then plugged in the MCU-Link PRO to pins 2 on J11 & J13. We're using the supplied 14 way cable that plugs into J19 on the MCU-Link PRO, using pin 9 as UART TX and pin 8 as UART RX.

0 Kudos
Reply

2,227 Views
marek-trmac
NXP Employee
NXP Employee

Hi keith1,

about VID and PID, just go to connection dialog and enter custom VID and PID value. There should not be any limitation. The default value should match the default value for the processor, however the settings is still editable.

About MCU Link Pro, in the past we used it for I2C and SPI communication.

Regards,
Marek
0 Kudos
Reply

2,242 Views
keith1
Contributor I

OS is Windows 10 and the SEC tool is version 5.0 (b220927)

0 Kudos
Reply

2,247 Views
liborukropec
NXP Employee
NXP Employee

Hello Keith,

could you please confirm what version of SEC tool are you using and what operating system and version as well?

 

Thank you,

Libor

0 Kudos
Reply