Fail to install due to older version of Microsoft Visual C++ distribution version

cancel
Showing results for 
Search instead for 
Did you mean: 

Fail to install due to older version of Microsoft Visual C++ distribution version

251 Views
VicKrawciw
Contributor I

Hi

I cannot install SPT due to the Microsoft Visual C++ distribution requirement being older than the one I currently have installed. How can I resolve this?

 

Thanks

0 Kudos
4 Replies

230 Views
VicKrawciw
Contributor I

Thank you - yes that worked.

0 Kudos

222 Views
liborukropec
NXP Employee
NXP Employee

Hi Victor,

 

glad to hear, workaround worked. We have found issue in v5 installer detecting what MSVC++ version is installed. Also we have found (another) reliable a workaround, that might help other users.

The order of actions is important:

  1. Download SEC v4.1.1
  2. Download SEC v5
  3. Install SEC v5 - it fails, but required MSVC++ for run is installed
  4. Install SEC v4.1.1- it installs MSVC++ that is needed only to satisfy v5 installer
  5. Install SEC v5 - it skips MSVC++ installation because satisfied by previous step
  6. SEC v4.1.1 can be uninstalled

Regards,

Libor

237 Views
marek-trmac
NXP Employee
NXP Employee
Hi Victor,
see also chapter 9. Troubleshooting in User Guide, there is link to the problem resolution at MSDN forum. Unfortunately, it seems there is not simple solutions for all configurations.
Regards,
Marek
0 Kudos

239 Views
liborukropec
NXP Employee
NXP Employee

Hi Victor,

 

workaround posted here does not work for you?

https://community.nxp.com/t5/MCUXpresso-Secure-Provisioning/Secure-Provisioning-Tool-V5-b220825/td-p...

 

Regards,

Libor

0 Kudos