lpcxpresso54608_rtos_examples_freertos_usart

cancel
Showing results for 
Search instead for 
Did you mean: 

lpcxpresso54608_rtos_examples_freertos_usart

354 Views
Contributor III

Hi,

"lpcxpresso54608_rtos_examples_freertos_usart" debug problem

The example works fine if it is just resumed in debug mode.

When any breakpoint is added or step over used inside uart_task() the debug hangs on eg. USART_RTOS_Init() or USART_RTOS_Send(). Suspend does not work then.

On "Terminate" I get "Connection is shut down" after long time.

When I restart debugging again I get the error:

"Flash Driver V.2 dynamic startup ignored - driver Init provided no info in STATUS. op Terminate (0x0, 0x0, 0x0) status 0x40 - driver reports init failure - EXTSPI driver rc13 - No supported SPIFI device..."

Less important debug topic in SDK usart examples:

In examples "lpcxpresso54608_driver_examples_usart_interrupt_transfer" and "lpcxpresso54608_driver_examples_usart_interrupt_rb_transfer" I observed an another issue during debuging.

Callback is often not noticed during step over "while (txOnGoing) {}". The simplest workaround is set a breakpoint after the loop before the loop is reached.

SDK_2.x_LPCXpresso54608 2.2.0

MCUXpresso IDE v10.0.0 [Build 344] [2017-03-21]

Eval Board OM13092 / LPCXpresso54608 rev.B

best regards

J.

0 Kudos
2 Replies

7 Views
NXP Employee
NXP Employee

With regards to your debug issue - there is an issue with the Linkserver FreeRTOS thread aware debugging support using a default "All-stop" debug connection.

To avoid this, with no debug connection active, delete any .launch file in your project. Then click on Quickstart Panel - Debug button, and when you probe is found , ensure that you select "Non-stop" debug mode (as shown in the screenshot in the MCUXpresso IDE v10.0.0 User Guide, section 3.3, "LinkServer Debug Operation").

The next release MCUXpresso IDE, expected next month, will disable FreeRTOS thread awareness when using a "Non-stop" debug mode to prevent this problem.

Regards,

MCUXpresso IDE Support

7 Views
Contributor III

Default was Non-Stop. In All-Stop mode it is OK. Thanks.

Another method to switch (without deleting launch files): remove Link2 USB plug, press Debug. When detection failed, insert the USB plug, select Search for LinkServer again and All-stop mode.

It looks the default setting can be changed as described here Debug Instance freezes after breakpoint when using FreeRTOS TAD 

P.S. The solution seems not to work for "lpcxpresso54608_driver_examples_usart_interrupt_rb_transfer" debug issue

but it is no problem for me (breakpoint after the loop is enough workaround).

kind regards

0 Kudos