lpc5460x "Hello world vcom" sample problem on USB1

cancel
Showing results for 
Search instead for 
Did you mean: 

lpc5460x "Hello world vcom" sample problem on USB1

Jump to solution
925 Views
cybaluke
Contributor III

Hi, I'm working with the sample demo "lpcxpresso54608_hello_world_virtual_com" from SDK 2.4.0 with an LPC54608, I'm using MCUxpresso 10.2.0 and my board is the OM13092UL.

When I work on USB0 (on J3 FullSpd) the dbg console is routed on VCOM as I expected.

When I try to change the virtual com from USB0 to USB1 port (J2 HighSpd) changing the settings:

/*! @brief LPC USB IP3511 FS instance count */
#define USB_DEVICE_CONFIG_LPCIP3511FS (0U)

/*! @brief LPC USB IP3511 HS instance count */
#define USB_DEVICE_CONFIG_LPCIP3511HS (1U)

when I launch the debug session of the new code the host WIN10 O.S. get an error and it doesn't recognize the new virtual com device attached. What I'm missing to changing from USB0 to USB1 the VCOM on this sdk sample code?

Regards

1 Solution
303 Views
miguel_mendoza
NXP Employee
NXP Employee

Hi cybaluke,

Apparently, the example "Hello world vcom" from the SDK, has some problems running with High Speed, as you say don't recognize the port, I recommended to use the "dev_cdc_vcom_bm" in the usb_examples section, this is very similar to the hello world example and run well with high speed, you only have to change the settings as you try before.

regards,
Miguel

View solution in original post

2 Replies
304 Views
miguel_mendoza
NXP Employee
NXP Employee

Hi cybaluke,

Apparently, the example "Hello world vcom" from the SDK, has some problems running with High Speed, as you say don't recognize the port, I recommended to use the "dev_cdc_vcom_bm" in the usb_examples section, this is very similar to the hello world example and run well with high speed, you only have to change the settings as you try before.

regards,
Miguel

303 Views
cybaluke
Contributor III

... any idea or help about my issue?

0 Kudos