evkmimrt1060_csi_ccir656 rgb565

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 

evkmimrt1060_csi_ccir656 rgb565

695 次查看
tomtalkington
Contributor III

I ran this driver demo with the supplied camera and LCD for my kit.  It works but the focus is set at about 2cm from the camera lens.  Is this normal behavior or do I have something setup wrong?  The datasheet for the MT9M114 claims autofocus.  New to cameras and video in general.  Any pointers would be appreciated.

Best regards,

Tom

标记 (4)
0 项奖励
2 回复数

597 次查看
igorpadykov
NXP Employee
NXP Employee

Hi Tom

in general such command (turn on autofocus) can be added to driver, however

from available datasheet sensor seems autofocus is not supported

https://www.onsemi.com/pub/Collateral/MT9M114-D.PDF 

One can contact vendor support for additional details

Technical Support | ON Semiconductor 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

597 次查看
tomtalkington
Contributor III

Thanks Igor.  Looks like the problem was a simple mechanical adjustment of the lens on the camera.  Be careful as it is easy to scratch the lens.  Luckily I had two cameras.  Had to turn it clockwise a couple of turns using the demo app to see the image for fine tuning. 

0 项奖励