Why do I not measure a clock pulse when running I2C example

cancel
Showing results for 
Search instead for 
Did you mean: 

Why do I not measure a clock pulse when running I2C example

189 Views
mbra16
Contributor II

I'm doing a project that includes I2C communication with an LPC804 as master. I'm using the breakout board "LPCXpresso804 board". I started out with an example code from the SDK to MCUXpresso called "lpc_i2c_polling_b2b_master_transfer" to get an idea about what I need to have get I2C to work. The example chooses pin "P0_14" as SCL and "P0_7" as SDA. 

Nevertheless, when I run the example code I can not measure any clock-like signals on the SCL line, and nothing at all on the SDA line. 

Any ideas as why this can be? Is there something I have to set up that I didnt see in the example?
I put a while(1) loop in there to make the MCU keep sending the same message over and over again, so the problem is not simply that I started measuring after the I2C communication happened. I'll upload a picture from the main loop.Udklip.PNG

This is the first time I'm working on anything not-Arduino, so forgive me if I'm being ignorent on the topic.

Tags (2)
0 Kudos
1 Reply

127 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello  Martin Busk Rasmussen ,

Have you connect the I2C slave board?  Master need get ACK from slave.

You can refer to the readme.txt under project to connect .


Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------