SDK_2.8.0 for LPC844 - PINT setting for GPIO Pin problem

cancel
Showing results for 
Search instead for 
Did you mean: 

SDK_2.8.0 for LPC844 - PINT setting for GPIO Pin problem

Jump to solution
44 Views
Contributor II

I am trying to add a PINT Peripheral to my project to allow for 4 GPIO pins to cause an interrupt if any of them detect a falling edge (this is for a 4x4 matrix keypad). The original project was in CW10.1 for a 9SQE32 MCU and with that I simply used Device Initialization for "KBI1" module of the MCU, set the 4 desired pins to "Pullup Enabled, Falling Edge Detect" and set ISR name "vKeyboard", then added my code for this to the outline ISR that was produced by CodeWarrior. Easy Stuff!

With MCUXpresso I see I can add a PINT peripheral for this, and am attempting to add these 4 GPIO pins to it, but PINT presents a dropdown pin list showing only PIN36...?? There does not seem to be a setting where I can select any of the four the GPIO pins I wish, PIO1_0 thru PIO1_3:

GPIOPINS.jpg

 

 

PINTSettings.jpg

Ultimately I want to add all four of these GPIO to PINT to generate a falling edge interrupt if *any* of them fall, the ISR will decode the key using 4 output GPIO pins to 'scan' the keypad, as I did with the QE32 MCU. 

Question: Bug here(?), or what I am seemingly doing wrong in setting this up? Perhaps I misunderstand the PINT Peripheral and am trying to implement this simple "4 GPIO to 1 ISR" incorrectly and should be setting them up manually using the API commands like "GPIO_IntCmd(LPC_GPIO_PIN_INT, c_controllerPort, c_controllerPin, GPIOPININT_FALLING_EDGE);"?

Cheers in advance!

0 Kudos
1 Solution
30 Views
Contributor II

Found it! 

Under PINS, these pins need to be assigned to PINT also, clicking on the pin in the PINT column and selecting the PINT# there, THEN it will appear in the list under Peripherals as expected.

Solved.

View solution in original post

0 Kudos
1 Reply
31 Views
Contributor II

Found it! 

Under PINS, these pins need to be assigned to PINT also, clicking on the pin in the PINT column and selecting the PINT# there, THEN it will appear in the list under Peripherals as expected.

Solved.

View solution in original post

0 Kudos