MCUXpresso v. 10.3.1_2233 IDE errors when attempting to import SDK_2.5.0_EVK-MIMX8MM.

cancel
Showing results for 
Search instead for 
Did you mean: 

MCUXpresso v. 10.3.1_2233 IDE errors when attempting to import SDK_2.5.0_EVK-MIMX8MM.

435 Views
kmarcinkowska
Contributor I

MCUXpresso v. 10.3.1_2233 IDE errors when attempting to import  SDK_2.5.0_EVK-MIMX8MM.  I tried loading a different SDK (SDK_2.5.0_EVK-MIMRT1015) and it worked just fine.  Is there any solution to this?  Perhaps a minor change to a manifest file will correct this issue?

pastedImage_1.png

0 Kudos
8 Replies

240 Views
kmarcinkowska
Contributor I

Yeah I know. I just a shame that we put some code up on something called " nxp MCUXPRESSO sdk" and it doesn't work on the "mcu Expresso ide". You have to admit that is a little confusing.  I mean maybe we could still allow the sdk to be imported but...oh wait just a second...use a different compiler tool chain such as gcc...shocking

0 Kudos

240 Views
joanxie
NXP TechSupport
NXP TechSupport

yes, sorry for confusing. you can find more detailed information from the link as below:

i.MX Software | NXP 

pls find MCUXpresso SDK for i.MX Cortex-M "

0 Kudos

240 Views
joanxie
NXP TechSupport
NXP TechSupport

the MCUpresso IDE doesn't support imx8 series SDK, only supports GCC ARM or IAR

0 Kudos

240 Views
kmarcinkowska
Contributor I

Ok it looks like i need to use a different tool/IDE the documentation state "except MCUXpresso"

0 Kudos

240 Views
kmarcinkowska
Contributor I

Should i use a different tool for this SDK?

0 Kudos

240 Views
kmarcinkowska
Contributor I

lets compare

SDK_2.5.0_EVK-MIMXRT1015

in EVK-MIMXRT1015_manifest_v3_4

</defines>
<ksdk id="MCUXpresso250" name="MCUXpresso250" version="2.5.0"/>

<toolchainSettings>
<toolchainSetting id="com.nxp.mcuxpresso" name="mcuxpresso" version="10.3.1" full_name="MCUXpresso IDE" compiler="compiler_gcc" toolchain="mcuxpresso">

SDK_2.5.0_EVK-MIMX8MM

in EVK-MIMX8MM_manifest_v3_3

</defines>
<ksdk id="KSDK250" name="KSDK250" version="2.5.0" revision="de6cf8db0eb 2019-01-07"/>

<toolchains>
<toolchain id="armgcc" name="GCC_ARM_Embedded" full_name="GCC ARM Embedded" type="armgcc" compiler="compiler_gcc" version="7.2.1" vendor="GCC ARM Embedded" vendor_url="http://launchpad.net/gcc-arm-embedded"/>
<toolchain id="iar" name="IAR_Embedded_Workbench_for_ARM" full_name="IAR Embedded Workbench for ARM" type="iar" compiler="compiler_iar" version="8.30.1" vendor="IAR Systems" vendor_url="http://www.iar.com"/>
</toolchains>

0 Kudos

240 Views
kmarcinkowska
Contributor I

Looks like the xml entries in the manifest file do not mention MCUXPRESSO. Comparing with other sdks the manifest mention this as a tool chain. This is the likely cause.

0 Kudos

240 Views
kmarcinkowska
Contributor I

the error log shows the following

eclipse.buildId=unknown
java.version=1.8.0_181
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86

com.nxp.mcuxpresso.core.datamodels
Error
Mon Jun 03 12:52:24 CDT 2019
The SDK 'SDK_2.x_EVK-MIMX8MM' does not contain any MCUXpresso IDE compatible toolchain.

at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.addToMap(SDKManifestProvider.java:848)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.access$0(SDKManifestProvider.java:835)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$3.visitFile(SDKManifestProvider.java:653)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$3.visitFile(SDKManifestProvider.java:1)
at java.nio.file.Files.walkFileTree(Files.java:2670)
at java.nio.file.Files.walkFileTree(Files.java:2742)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.refresh(SDKManifestProvider.java:618)
at com.nxp.mcuxpresso.core.datamodels.SDKChipVendorDatabase.refresh(SDKChipVendorDatabase.java:788)
at com.nxp.mcuxpresso.core.datamodels.ui.views.SDKView.doDBRefresh(SDKView.java:1252)
at com.nxp.mcuxpresso.core.datamodels.ui.jobs.SDKImportJob.run(SDKImportJob.java:100)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56)

eclipse.buildId=unknown
java.version=1.8.0_181
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86 -data file:/C:/Users/kmarcinkowska/Documents/MCUXpressoIDE_10.3.1_2233/workspace/

com.nxp.mcuxpresso.core.datamodels
Error
Mon Jun 03 10:59:12 CDT 2019
The SDK 'SDK_2.x_EVK-MIMX8MM' does not contain any MCUXpresso IDE compatible toolchain.

at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.addToMap(SDKManifestProvider.java:848)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.access$0(SDKManifestProvider.java:835)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$3.visitFile(SDKManifestProvider.java:653)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider$3.visitFile(SDKManifestProvider.java:1)
at java.nio.file.Files.walkFileTree(Files.java:2670)
at java.nio.file.Files.walkFileTree(Files.java:2742)
at com.nxp.mcuxpresso.core.datamodels.providers.SDKManifestProvider.refresh(SDKManifestProvider.java:618)
at com.nxp.mcuxpresso.core.datamodels.SDKChipVendorDatabase.refresh(SDKChipVendorDatabase.java:788)
at com.nxp.mcuxpresso.core.datamodels.ui.views.SDKView.doDBRefresh(SDKView.java:1252)
at com.nxp.mcuxpresso.core.datamodels.ui.jobs.SDKImportJob.run(SDKImportJob.java:100)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56)

0 Kudos