MCUXpresso IDE Error: Unable to import SDK. Already exists.

cancel
Showing results for 
Search instead for 
Did you mean: 

MCUXpresso IDE Error: Unable to import SDK. Already exists.

693 Views
pcpro178
Contributor III

I'm trying to reinstall the SDK for MKL17Z256xxx4 because when I tried to install a SDK that I had downloaded some months ago, it gave me a warning about something being missing or out of date.  I deleted the SDK by right-clicking it in the Installed SDKs view and selecting the option in the context menu for Delete SDK.  I then downloaded a newly built SDK and tried to install it by dragging the zip file into the Installed SDKs view.  That's when I got this error: "Unable to import SDK_2.4.1_MKL17Z256xxx4.zip. Already exists."  I even tried restarting the IDE with the same results.  How can I fix this error, so that I can install the SDK?

Labels (1)
Tags (2)
0 Kudos
4 Replies

282 Views
jorge_a_vazquez
NXP Employee
NXP Employee

Hi Jim Fell

Could you clarify what MCUXpresso IDE version are you using? I would recommend you to use our latest Version 10.2.1

Also, could you go to the default locations of all your SDK installed and verify that there isn't any SDK_x.x.x_MKL17Z256xxx4.zip package on it? you can right-click  and select "open default location"

Best regards

Jorge Alcala

0 Kudos

282 Views
pcpro178
Contributor III

I ended up deleting the workspace and making a new one.  Since then, I discovered an mcuxpresso folder in my user directory.  It looks like MCUXpresso saves packages here deleting the right sub-folder(s) here could probably have resolved the problem without making a new workspace.

pastedImage_1.png

0 Kudos

282 Views
BlackNight
NXP Employee
NXP Employee

Hi Jim,

you can open the SDK location from the Installed SDKs view:

pastedImage_1.png

I hope this helps,

Erich

282 Views
pcpro178
Contributor III

Thanks Erich.

0 Kudos