Impossible to build MCUXpresso project based on imported SDK through Jenkins

cancel
Showing results for 
Search instead for 
Did you mean: 

Impossible to build MCUXpresso project based on imported SDK through Jenkins

1,021 Views
nicolaslignée
Contributor I

Hello,

I try to build a MCUXpresso project though Jenkins for a while. The fact is that I have a java exception at the end of the build through Jenkins that I don't have in MCUXpresso. When I go to the .log file, it seems that this java exception is raised because Jenkins doesn't find the "part support" for the project (in my case the MCU KW41Z512xxx4).
By testing a lot of different configurations, here are all my clues :

- The build is working with a project based on a preinstalled MCU
- The build is not working with a project based on a imported MCU
- The command used to build in Jenkins works fine in the windows command prompt
- When I launch a command prompt from Jenkins with the same command than on windows, it doesn't work

It seems that Jenkins is not able to find the SDK configuration imported to build the project.

Any idea to solve the problem ?

thank you.

Nicolas  

Tags (2)
0 Kudos
5 Replies

324 Views
lpcxpresso_supp
NXP Employee
NXP Employee

If you are building a project based on an MCU supplied via an SDK (as opposed to the built-in parts), then your machine needs to have the SDK containing the part support for the target MCU installed on it in order for the IDE to function correctly.

Can you confirm if your machine has the SDK installed, and if so - where is it installed? In the default location?

Regards,

MCUXpresso IDE Support

0 Kudos

324 Views
nicolaslignée
Contributor I

Hello,

As required by the User Guide, I downloaded the SDK from NXP website "build your SDK", I dragged and dropped the ZIP file in the tab "Installed SDKs" and that's it.

This morning, by opening my IDE, I found this on the Error Log tab :

part_support.PNG

In fact, even MCUXpresso doesn't find the part support, but contrary to Jenkins, It seems to be able to installed the device after-all.

What is the meaning of "Part support does not match current product build number" ?

Thank you for your interest.

Regards,

Nicolas Lignée

0 Kudos

324 Views
kushal_dumre
Contributor I

Hi Nicolas,

Were you able to solve this problem?

I am currently trying to build a project in MCUxpresso from jenkins in windows. Any suggestion from your side will be really helpful as you also have faced this problem previously.

Thanks and best wishes!

0 Kudos

324 Views
nicolaslignée
Contributor I

Hi Kushal,

Yes, I solved my problem. It is working fine now.

To summarize the solution I found : Jenkins is not using the "same" MCUXpresso than Windows. The SDK installed in MCUXpresso was not reachable by Jenkins. I had to allow Jenkins to use the desktop, go to what I called "the background of Windows" where Jenkins is working and install the SDK in the MCUXpresso that I found there. (By asking Jenkins to open a MCUXpresso workspace and wait a bit to let me the time to investigate).

Do you have any blocking point ?

Best regards,

NIcolas

0 Kudos

324 Views
kushal_dumre
Contributor I

Hi Nicolas,

I was in breaking point but i have solved my problem somehow.

What was happening was, i was trying to run commands from cmd windows but the import was not working correctly. so instead of using following,

-import "path_of_my_project"

From cmd windows, i went to the the project directory with (cd) and ran command there without import command.

It seems to work fine for now,  the building task.

Taking advantage of this moment, i would like to ask you something else.

Now  my idea is to flash the debug board with the artifacts (.a and .bin) generated by the previous build, and its not too direct because of the sophisticated process. Main objective is to automatize the whole process, from build to deploy.

Please share your experience if you had happened to tried this .

Thank you very much for your kind response.

0 Kudos