problem with Debug using frdm k64f

cancel
Showing results for 
Search instead for 
Did you mean: 

problem with Debug using frdm k64f

325 Views
francoruben
Contributor I

Hi, im having some problems with the debug. I'm trying to debug a Hello World example. I create the project, i build it, but when i try to debug the project, a window appears. I cant find mi board on this window, how can i solve it? thanks

pastedImage_1.png

0 Kudos
1 Reply

116 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

Hi Franco,

From your screenshot, your IDE try to load DAPLink  Server but couldn't find this interface.

First please check which debug interface do you work with ?  If you don't know, please check it in Device manager. for example, here is my FRDM-K64F interface. I use Jlink OpenSDA.

pastedImage_1.png

What interface do you work with?

I suggest you:

1. remove current launch configurations in debug configuration.

2. relaunch debugger, it will force IDE check all the possible interface connections. then set connection.

see attached video for both of the points I am talking with.

If all above can not help, please check if this thread answered by MCUXpresso expert can help you

https://community.nxp.com/thread/450279 


Have a great day,
Jennie Zhang

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos