mcuxpressoide: Unhandled event loop exception, no more handles.

cancel
Showing results for 
Search instead for 
Did you mean: 

mcuxpressoide: Unhandled event loop exception, no more handles.

137 Views
pburkacki
Contributor I

Hello,

I am running into an issue while trying to import a project into mcuxpresso.  I think this might be something related to Eclipse and not specifically the mcuxpresso IDE.  I have been digging on the web and in NXP forums but have not been able to find an answer.

I installed mcuxpresso version v11.3.1, build 5256, 2021-04-2.  This is on a system running Ubuntu 16.04.  From the main menu, File -> Import -> General -> Existing Projects into Workspace.  When I click the Browse button of the "Select root directory" drop down, I get the "no more handles error".

mcuxpresso_ide_no_handles.png

Here is the error log:

mcuxpresso_ide_no_handles_error_log.png

At the same time, the console dumps the following but I don't think that is the root cause (although the SWT GTK warning does stand out)

mcuxpressoide
***WARNING: GTK+ version too old (micro mismatch)
***WARNING: SWT requires GTK 3.20.0
***WARNING: Detected: 3.18.9

(MCUXpresso IDE:8019): Gtk-WARNING **: Theme parsing error: <data>:7:18: '-gtk-key-bindings' is not a valid property name

(MCUXpresso IDE:8019): Gtk-WARNING **: Theme parsing error: <data>:31:11: 'min-height' is not a valid property name

Any help is appreciated.

Paul

0 Kudos
2 Replies

133 Views
pburkacki
Contributor I

A quick update.

I did some more digging and I found that the Installation Guide for version 11.3.0 of the IDE mentions support for Ubuntu 18.04 and 20.04 only.  I installed version 11.3.1 since that is the most recent one.

However, there are other developers who have installed and successfully used mcuxpressoide on their systems which are also 16.04.  Although in their case, the version of the IDE is 11.2.  That might be the issue but could it be that OS support between versions 11.3.1 and 11.2 has changed this much?

Paul

0 Kudos

129 Views
converse
Senior Contributor V

"could it be that OS support between versions 11.3.1 and 11.2 has changed this much?"

In a word - yes!

Try a version of the IDE that IS supported in your version of Ubuntu - 16.04 is now over 5 years old and you are unlikely to get much support/sympathy from NXP for trying to run on an unsupported OS.

0 Kudos