Update MCUXpresso IDE keeping SDK's

cancel
Showing results for 
Search instead for 
Did you mean: 

Update MCUXpresso IDE keeping SDK's

118 Views
Contributor I

I'm learning to use and get used to MCUXpresso by testing it on a small test project a LPC845-BRK.

I started with MCUXpresso IDE v11.2.0_4120, installed a few SDK's (LPC845BREAKOUT, LPCXpresso.. )

However i yesterday updated to MCUXpresso IDE v11.2.1_4149 by downloading the package and installing it. New version in parallel to existing version.

However on starting the new version all SDK's are gone!

Do i have to install all SDK's again each time an update is done (approx 4 times a year)?
At the moment i only have 2 installed but once we make te full transition to MCUXpresso multiple machines will need the update.

Is installing a new version of MCUXpresso to a general directory (without version number)(eq C:\ nxp\MCUXpressoIDE\ ) recommended and would that keep all installed SDK's?

0 Kudos
6 Replies

86 Views
Contributor I

If you installed your SDKs using the "Plugin SDK" mechanism, so directly installing them from within the IDE itself, then the SDK are effectively standard Eclipse plugins. Thus they can be imported from an old install of the IDE to your new one using the Eclipse plugin import mechanism described in the IDE's Installation Guide ....

To do this, from your new installation select File -> Import -> Install -> From Existing
Installation and point at the ide directory within your original IDE’s installation directory. Note:
that on macOS / Linux – this option will effectively run automatically the first time you run the
new version of the IDE.

Of course, you might want to instead take the opportunity to also update to a newer version of the SDK that may be available for use with the newer version of the IDE.

Hope this helps!

0 Kudos

75 Views
Contributor I

abnxpweb , Tried you suggestion but got stuck on to which directory i have to point.

message: Specify the path to a valid application installation. Error remains on all paths.

paths tried: C:\nxp\MCUXpressoIDE_11.2.0_4120  (and some sub.paths)
and path from SDK (which is an empty directory)

EDIT:
i tried "C:\nxp\MCUXpressoIDE_11.2.0_4120\ide" and got the option!
selected both SDK and they got copied and after a reboot appear in my new IDE.

Conslusion: is that SDK need to be installed or copied for every new IDE installation.

This is different from the way ErichS describes as he seems to keep one version of each SDK installed, they way i would prefer.

0 Kudos

54 Views
Contributor I

Yes, as the IDE's Installation Guide text implies (though I agree you could misread this), you have to point at the actual "ide" subdirectory within the installation directory.

Of course, as Erich points out there are other ways of installing and handling SDKs - but you were asking about the plugin SDK system, which I think you now have a migration solution for.

There is lots more information on the various options for installing SDKs contained within the IDE's User Guide if you want to look further into what Erich suggests - so you might want to read that too.

[TBH - its a bit annoying that NXP haven't updated their User Guide to explicitly cover the migration of plugin SDKs from one version to another.]

Anyway, hope this helps!

0 Kudos

108 Views
Senior Contributor II

Hi @bwinter ,

I have done the same (installing new IDEs (of course in different folders) and it kept the previously installed SDKs as they are shared between the IDEs. If you have many SDKs, it takes a few minutes to list them in the View.

If not: try to do a refresh if this helps?

ErichS_0-1605855994780.png

Check the SDK preferences:

ErichS_1-1605856047675.png

And it should show you the SDK location:

ErichS_2-1605856074500.png

Can you check this?

I hope this helps,

Erich

0 Kudos

77 Views
Contributor I

ErichS, thanks for your help.

I did the refresh -> no difference.
Took a look at the SDK location the way you described. -> both installs have exact the same path and all settings are exact the same as the ones in your picture. The only difference is of course my username is different.

I then went to the mentioned directory: "....\mcuxpresso\02\SDKPackages". the directory is empty!?

I do have SDK's installed.
Two under my old "MCUXpresso IDE v11.2.0_4120" version and
One (installed yesterday through IDE install SDK because i wanted to continue) in my new "MCUXpresso IDE v11.2.1_4149" version.

The two SDKs from the old version are still not available in  the new version.
(tried the option from the post by abnxpweb but got stuck on to which directory i have to point)

0 Kudos

42 Views
Senior Contributor II

Hi @bwinter ,

not sure what it is. To my understanding the path naming with  "....\mcuxpresso\02\SDKPackages" has been introduced to keep up with SDK version changes.

Have you tried to import (drag&drop) the SDK(s) into the new version? Maybe this fixes it?

 

I hope this helps,

Erich

0 Kudos