SWT_GTK3 problem when trying to run Linux mcuxpresso_ide via remote desktop?

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SWT_GTK3 problem when trying to run Linux mcuxpresso_ide via remote desktop?

Jump to solution
850 Views
np
Contributor IV

I'm trying to remotely login to the desktop of our mcuxpresso headless build server Linux machine (which I've never done before). I'm able to ssh -X in, launch tightvncserver (having chmodded ~/.Xauthority), work out the port number from the log file, and then use Windows Remote Desktop to get VNC access to a grey desktop (via the port). Basically, I can get in and navigate the desktop (e.g. edit text files etc) OK, so everything is looking as though it ought to work.

However, when I try to right-click-launch mcuxpressoide from the desktop --> Applications --> Development, it silently refuses to start up. The vnc log file reports a single enigmatic error message:

env: ‘SWT_GTK3’: No such file or directory

So the problem is almost certainly that, like running mcuxpressoide from the command line, I need to set SWT_GTK3=0 (to force it to use GTK2 rather than GTK3). To do this, I suspect I need to edit some .ini file somewhere (maybe /ide/mcuexpresso_ide.ini ?) to forcibly set the environment variable SWT_GTK3=0, but I can't see where or how.

What am I missing here? Thanks!

Tags (1)
0 Kudos
Reply
1 Solution
823 Views
np
Contributor IV

Hi Jennie,

Unfortunately, I had already tried all the tips and tricks in that webpage.

But luckily, I managed to work out how to make it work in a slightly different way. Here are the steps:

  • ssh -X to the remote server
  • tightvncserver
  • cat the log file mentioned in the tightvncserver startup text, e.g.
    • 25/10/22 15:42:05 Listening for VNC connections on TCP port 5902
      Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
      Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
      No VNC extension on display :2
  • From this log, you need the TCP port number (here = "5902") and display reference (here = ":2")
  • Use Remote Desktop to login to the server (using the "vnc-any" option and the TCP port number)
  • From the ssh terminal, launch MCUXpresso while also specifying the display on the command line, e.g.
    • DISPLAY=":2" SWT_GTK3=0 UBUNTU_MENUPROXY=0 /usr/local/mcuxpressoide-<version>/ide/mcuxpresso
      ide

I hope this helps anyone else who finds themselves stuck on this step!

Cheers, Nick

View solution in original post

0 Kudos
Reply
2 Replies
824 Views
np
Contributor IV

Hi Jennie,

Unfortunately, I had already tried all the tips and tricks in that webpage.

But luckily, I managed to work out how to make it work in a slightly different way. Here are the steps:

  • ssh -X to the remote server
  • tightvncserver
  • cat the log file mentioned in the tightvncserver startup text, e.g.
    • 25/10/22 15:42:05 Listening for VNC connections on TCP port 5902
      Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
      Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
      No VNC extension on display :2
  • From this log, you need the TCP port number (here = "5902") and display reference (here = ":2")
  • Use Remote Desktop to login to the server (using the "vnc-any" option and the TCP port number)
  • From the ssh terminal, launch MCUXpresso while also specifying the display on the command line, e.g.
    • DISPLAY=":2" SWT_GTK3=0 UBUNTU_MENUPROXY=0 /usr/local/mcuxpressoide-<version>/ide/mcuxpresso
      ide

I hope this helps anyone else who finds themselves stuck on this step!

Cheers, Nick

0 Kudos
Reply
834 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

Hi 

Please check this FAQ

https://community.nxp.com/t5/LPCXpresso-IDE-FAQs/Installing-LPCXpresso-on-Linux/m-p/470769

it includes setting GTK3 which may help you.

Hope it helps,

Jun Zhang

 

0 Kudos
Reply