SEGGER J-Link configurations don't show up in MCUXpresso IDE

cancel
Showing results for 
Search instead for 
Did you mean: 

SEGGER J-Link configurations don't show up in MCUXpresso IDE

Jump to solution
499 Views
laszlomonda
Contributor IV

Hi there,

I'm back to firmware development after a long break, and I've just realized that I can't flash firmware with SEGGER J-Link via MCUXpresso IDE 10.3.1 on Linux anymore.

Our project is open source. See the .launch files. I can see uhk60-right_debug_kboot and uhk60-right_release_kboot under External Tools Configurations, but I can't see the uhk60-right_debug_standalone_jlink configuration anywhere, including Debug Configurations and Run Configurations.

When I double-click on the "GDB SEGGER Interface Debugging" menu item of the Debug Configurations dialog, I get a dialog featuring:

"An error has occurred. See error log for more details.
java.lang.NullPointerException"

JLinkExe works from the command line, but I can't use SEGGER JLink from MCUXpresso IDE. Any help would be appreciated.

- Laci

0 Kudos
1 Solution
321 Views
BlackNight
NXP Employee
NXP Employee

I missed to mention that you have to have a project selected:

pastedImage_1.png

You can read the project selected in the IDE quickstart panel (marked in yellow above).

I hope this helps,

Erich

View solution in original post

0 Kudos
7 Replies
321 Views
BlackNight
NXP Employee
NXP Employee

Hi Laci,

I believe I reported that issue with the NPE already, so I think this will be fixed in the upcoming release.

The workaround (and usual way to create/launch a debug session) is to use the 'blue' debug icon in the toolbar: this will automatically create the correct launch/debug configuration.

Can you try this if this works for your project?

I hope this helps,

Erich

321 Views
laszlomonda
Contributor IV

Thanks Erich!

Unfortunately, the blue debug icon is greyed out for me, even after booting the debug probe.

What NPI stands for?

0 Kudos
321 Views
BlackNight
NXP Employee
NXP Employee

NPI was a type, I wanted to write NPE (Null Pointer Exception).

About the debug icon: make sure you are in the develop perspective:

pastedImage_1.png

I hope this helps,

Erich

0 Kudos
321 Views
laszlomonda
Contributor IV

I'm in develop perspective, but the blue bug icon is still greyed out.

Untitled.png

0 Kudos
322 Views
BlackNight
NXP Employee
NXP Employee

I missed to mention that you have to have a project selected:

pastedImage_1.png

You can read the project selected in the IDE quickstart panel (marked in yellow above).

I hope this helps,

Erich

View solution in original post

0 Kudos
321 Views
laszlomonda
Contributor IV

You're right, Erich! The project was already selected, but the blue bug icon was greyed out. Strangely, I have to open the quickstart panel, then go back to the project explorer, then the icon becomes clickable. This is very weird, but solved the issue.

0 Kudos
321 Views
BlackNight
NXP Employee
NXP Employee

The 'blue' debug icon is linked with the quickstart panel, so you need to have this one open. That's why in the normal 'debug' perspective the blue icon might be disabled too.

0 Kudos