Right clicking on project explorer does not work

cancel
Showing results for 
Search instead for 
Did you mean: 

Right clicking on project explorer does not work

328 Views
Contributor II

I am using MCUXpresso IDE v11.1.1 on Ubuntu 18.04.4 LTS and when I left click to any item on project explorer the menu does not show up. Am I missing some dependencies? I checked the dependencies but it seems I have all  the dependencies installed

0 Kudos
10 Replies

90 Views
Contributor II

Hi again,

I am sorry to hear that. I know it is a weird problem. Just for an uptdate, occasionally I am able to see the right click menu, but it is really rare. This rarity is not click wise rather it is IDE start wise. In other words, it is not like I am able to see the right click menu one in every hundred clicks. It is as follows, when I start the IDE if it does not work then for sure it will not work until IDE is closed. However, on some rare occasions right click menu does show up on every click again until the IDE is closed. Since, it is really rare I could not identify what might be the cause.

Best regards,

Salih

0 Kudos

90 Views
NXP TechSupport
NXP TechSupport

Hi Salih,

 

Today we released a new version of MCUXpresso IDE (v11.2.0).

Could you please try using this new version to see if the behavior persists?

 

Please let me know if your results.

 

Best regards,

Sebastian

0 Kudos

90 Views
Contributor II

Hi Sebastian,

Thanks for your interest in the topic. Problem continues in the new version.

Best regards,

Salih

0 Kudos

90 Views
NXP Employee
NXP Employee

Based on the information provided, it's difficult to say what might be going wrong in your setup. Also, I know this might sound weird but would you please try keeping right-click pressed on your mouse for about 2-3 seconds? I've seen similar behavior to what you describe when using VMs or when using VNC. However, "problem" was "solved" with the long-press of the right-click.

Maybe the information from the workspace log has some useful information for tracking down the issue. Would you please attach that information? You can easily obtain it using Help => MCUXpresso Save Info for Support.

pastedImage_1.png

Greetings,
MCUXpresso IDE Support

0 Kudos

90 Views
Contributor II

Hello,

Sorry for the late response. I normally use the trackpad of my laptop, so I had to wait until I tried this with an external mouse since I cannot click longer periods of time with trackpad. With external mouse right click works normally, but the trackpad is still problematic. So, my previous comment claiming that the problem is related with the stating of the IDE turns out to be wrong since right clicking works with external mouse, but not with trackpad. Also, I was able to observe the behavior you described. Moreover, if file or folder is selected, it requires less time pressing mouse button than with not selected files or folders.

Lastly, I added the information you asked for.

0 Kudos

90 Views
NXP Employee
NXP Employee

Thank you for the logs. Unfortunately, there's no indication about the failure you're currently reporting. Moreover, according to your updates, I'm tempted to say that the problem is not necessarily related to the IDE. Would you please try the right-click use case on a stock Eclipse for C/C++ x86_64 on your machine? It would be nice to know whether the problem can be reproduced there as well. If it's not there, we'll need further investigation.

Greetings,
MCUXpresso IDE Support

0 Kudos

90 Views
Contributor II

The same problem happens on stock Eclipse too.

0 Kudos

90 Views
Contributor II

Thank you, hope you are doing well too.

I purged then reinstalled the ide following the document,  however, the problem still exist. Right click does work on other views but not on project explorer, which is the same as before.

Best regards,

Salih

0 Kudos

90 Views
NXP TechSupport
NXP TechSupport

Hi Salih,

 

Unfortunately, we haven't seen this behavior before, and have not been able to replicate it on a Ubuntu 18.04 LTS virtual machine with the latest MCUXpresso version installed.

 

Best regards,

Sebastian

0 Kudos

90 Views
NXP TechSupport
NXP TechSupport

Hi Salih, I hope you're doing well!

 

I tried replicating your issue, but unfortunately, I haven't been able to.

 

Could you please try fully uninstalling the MCUXpresso IDE and reinstalling it from scratch, following the MCUXpresso IDE Installation Guide? There's some additional details in the guide to consider.

 

Could you please let me know if you still have issues after reinstalling?

 

Take care, best regards,

Sebastian

0 Kudos