PATH settings in MCUXpresso IDE 11.2.0 build 4120

cancel
Showing results for 
Search instead for 
Did you mean: 

PATH settings in MCUXpresso IDE 11.2.0 build 4120

214 Views
Contributor I

Where can I edit the $PATH settings in the MCUXpresso IDE 11.2.0 for Windows x86_64 ? I've just installed this latest version of the IDE, tried to build one of my old projects and got this error:
     Program "make" not found in PATH.

I've double checked my installation and found "make" in the directory where it is expected to be:
   C:\nxp\MCUXpressoIDE_11.2.0_4120\ide\buildtools\bin

So clearly PATH is not correctly. How one can edit it ?

0 Kudos
4 Replies

108 Views
NXP Employee
NXP Employee

You can see all the variables in the build section (right-click project => Properties => C/C++ Build => Build Variables and make sure to tick "Show system variables"). However, given the fact that this fundamental thing is not working in your case, you'll probably run into some other problems after fixing the path variable.

Greetings,
MCUXpresso IDE Support

0 Kudos

108 Views
Contributor I

I followed (right-click project => Properties => C/C++ Build => Build Variables and make sure to tick "Show system variables"), found the "Path" variable and appended the path to the "make" utility which was missing, namely "C:\nxp\MCUXpressoIDE_11.2.0_4120\ide\buildtools\bin;". I applied the changes and then I restarted the IDE and tried to build my project. It failed the same as before with this message:


Error: Program "make" not found in PATH

PATH=[C:/nxp/MCUXpressoIDE_11.2.0_4120/ide/jre/bin/server;C:/nxp/MCUXpressoIDE_11.2.0_4120/ide/jre/bin;C:/nxp/MCUXpressoIDE_11.2.0_4120/ide/jre/lib/amd64;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;C:\Program Files\Hummingbird\Connectivity\14.00\NFS Maestro\;C:\Program Files (x86)\Hummingbird\Connectivity\14.00\NFS Maestro\;C:\Program Files\PuTTY\;C:\Program Files\TortoiseSVN\bin;C:\Program Files\dotnet\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\170\Tools\Binn\;C:\Users\212476878\AppData\Local\Microsoft\WindowsApps;;C:\nxp\MCUXpressoIDE_11.2.0_4120\ide;]

But the PATH in the error message still does not incorporate my latest addition, "C:\nxp\MCUXpressoIDE_11.2.0_4120\ide\buildtools\bin;". And the variable I edited through the menu was "Path" while the one in the error message is "PATH". So the question remains - how do I edit "Path" (or "PATH" ?) so that the IDE recognizes my changes ?

Thank you

0 Kudos

108 Views
Senior Contributor III

I think you need to change in a different place:

Window->Preferences

MCUExpresso IDE->Paths and directories

and edit the 'Additional Path directories' to ensure it contains paths to your files.

0 Kudos

108 Views
NXP TechSupport
NXP TechSupport

Hello Mikhail Maizelis ,

What about your project? Does it created by other version IDE?

How about create a new project?

Regards,

Alice

0 Kudos