MCUXpresso on WSL2 Ubuntu 20.04 LTS

cancel
Showing results for 
Search instead for 
Did you mean: 

MCUXpresso on WSL2 Ubuntu 20.04 LTS

Jump to solution
48 Views
brich
Contributor III

Is WSL2 supported using Ubuntu 20.04 LTS?  I would think so since Ubuntu 20.04 LTS is officially supported.  Not sure how WSL2 makes things any different, but this is the installation error I get:

brad@BRADR:/mnt/c/Users/Brad/Downloads$ sudo ./mcuxpressoide-11.3.1_5262.x86_64.deb.bin
Verifying archive integrity...  100%   All good.
Uncompressing mcuxpressoide installer  100%
Installing...
(Reading database ... 67071 files and directories currently installed.)
Preparing to unpack JLink_Linux_x86_64.deb ...
Removing /opt/SEGGER/JLink ...
Unpacking jlink (6.981) over (6.981) ...
Setting up jlink (6.981) ...
Failed to send reload request: No such file or directory
Selecting previously unselected package mcuxpressoide.
(Reading database ... 67071 files and directories currently installed.)
Preparing to unpack mcuxpressoide-11.3.1_5262.x86_64.deb ...
Unpacking mcuxpressoide (11.3.1) ...
Setting up mcuxpressoide (11.3.1) ...
Failed to send reload request: No such file or directory
dpkg: error processing package mcuxpressoide (--install):
 installed mcuxpressoide package post-installation script subprocess returned error exit status 1
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Errors were encountered while processing:
 mcuxpressoide
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up mcuxpressoide (11.3.1) ...
Failed to send reload request: No such file or directory
dpkg: error processing package mcuxpressoide (--configure):
 installed mcuxpressoide package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 mcuxpressoide
E: Sub-process /usr/bin/dpkg returned an error code (1)
0 Kudos
1 Solution
25 Views
brich
Contributor III

I was able to get this to work by installing MCUXpresso after installing the full-blown desktop version of Ubuntu 20.04 LTS in my WSL2.  

I followed the steps outlined here:

https://gist.github.com/Ta180m/e1471413f62e3ed94e72001d42e77e22

One difference, I added "-ac" as an optional parameter to VcXsrv in "single window" mode.  Not sure if it works in other modes, full screen etc.  But this is how I was able to get it to work.

Once logged into the desktop with the same username and password I used to install Ubuntu 20.04 LTS on WSL2, I proceeded through the normal install mechanism, and this time it installed.  I'm guessing the reason for the failures before in command-line only mode had to do with some installation scripts failing to setup things like the desktop shortcuts. 

All I needed was the tool to cleanly install, and now I'll be able to run command-line builds from within WSL using a bamboo remote build agent for our continuous integration builder.  Hope this helps someone else who also may be having this problem!

Cheers,

Brad

View solution in original post

0 Kudos
4 Replies
26 Views
brich
Contributor III

I was able to get this to work by installing MCUXpresso after installing the full-blown desktop version of Ubuntu 20.04 LTS in my WSL2.  

I followed the steps outlined here:

https://gist.github.com/Ta180m/e1471413f62e3ed94e72001d42e77e22

One difference, I added "-ac" as an optional parameter to VcXsrv in "single window" mode.  Not sure if it works in other modes, full screen etc.  But this is how I was able to get it to work.

Once logged into the desktop with the same username and password I used to install Ubuntu 20.04 LTS on WSL2, I proceeded through the normal install mechanism, and this time it installed.  I'm guessing the reason for the failures before in command-line only mode had to do with some installation scripts failing to setup things like the desktop shortcuts. 

All I needed was the tool to cleanly install, and now I'll be able to run command-line builds from within WSL using a bamboo remote build agent for our continuous integration builder.  Hope this helps someone else who also may be having this problem!

Cheers,

Brad

View solution in original post

0 Kudos
42 Views
brich
Contributor III
0 Kudos
25 Views
converse
Senior Contributor IV

It works on a proper Ubuntu installation - perhaps WSL2 is missing stuff...

Here is the (working) install log:

Verifying archive integrity... All good.
Uncompressing mcuxpressoide installer 100%
Installing...
Selecting previously unselected package jlink.
(Reading database ... 228626 files and directories currently installed.)
Preparing to unpack JLink_Linux_x86_64.deb ...
Removing /opt/SEGGER/JLink ...
/opt/SEGGER/JLink not found (OK)
Unpacking jlink (6.860) ...
Setting up jlink (6.860) ...
Selecting previously unselected package mcuxpressoide.
(Reading database ... 228981 files and directories currently installed.)
Preparing to unpack mcuxpressoide-11.2.1_4149.x86_64.deb ...
Unpacking mcuxpressoide (11.2.1) ...
dpkg: mcuxpressoide: dependency problems, but configuring anyway as you requested:
mcuxpressoide depends on libusb-1.0-0-dev.
mcuxpressoide depends on dfu-util; however:
Package dfu-util is not installed.

Setting up mcuxpressoide (11.2.1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu2) ...
Rebuilding /usr/share/applications/bamf-2.index...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
brasero-common cdrdao command-not-found-data cpp-5 cpp-7
deja-dup-backend-gvfs diffstat dvdauthor efibootmgr espeak-data
evolution-data-server-online-accounts fonts-stix gcc-7-base gcc-8-base
gcc-8-base:i386 gconf2-common geoip-database gettext gir1.2-geocodeglib-1.0
gir1.2-javascriptcoregtk-3.0 gir1.2-mutter-2 gnome-software-common gsfonts
guile-2.0-libs hardening-includes imagemagick-6-common imagemagick-common
intltool-debian iputils-arping liba52-0.7.4 libapparmor-perl libappstream3
libapt-pkg-perl libarchive-zip-perl libargon2-0 libasync-mergepoint-perl
libautodie-perl libavutil55 libb-hooks-endofscope-perl libbabeltrace-ctf1
libboost-date-time1.65.1 libboost-filesystem1.58.0 libboost-system1.58.0
libbrlapi0.6 libburn4 libcamel-1.2-54 libcapnp-0.5.3 libcapnp-0.6.1
libcapnp-0.7.0 libcapture-tiny-perl libcdio13 libcdio17 libcilkrts5
libclass-method-modifiers-perl libclone-perl libcloog-isl4
libclutter-gst-2.0-0 libcolamd2.9.1 libcomerr2:i386 libcroco3 libcryptsetup4
libcrystalhd3 libdevel-size-perl libdigest-bubblebabble-perl
libdns-export162 libdouble-conversion1 libdumbnet1 libdvdread4
libedataserver-1.2-21 libedataserverui-1.2-1 libefivar0 libegl1-mesa
libespeak1 libevent-2.0-5 libevent-2.1-6 libexempi3 libexporter-tiny-perl
libfcgi-perl libfcitx-gclient0 libffi6:i386 libfile-copy-recursive-perl
libfluidsynth1 libfont-ttf-perl libfreerdp-primitives1.1 libfuture-perl
libfwup0 libfwupd1 libgadu3 libgconf-2-4 libgcr-3-common libgeoclue0
libgeoip1 libgettextpo-dev libgettextpo0 libglew1.13 libgmime-2.6-0
libgmime-3.0-0 libgnome-desktop-3-12 libgnome-desktop-3-17 libgspell-1-1
libgssdp-1.0-3 libgtksourceview-3.0-common libgtkspell3-3-0 libgtop-2.0-10
libgutenprint-common libgutenprint2 libgutenprint9 libgweather-3-15
libgweather-3-6 libhogweed4 libhogweed4:i386 libhud2 libhunspell-1.3-0
libical1a libicu55 libilmbase12 libio-pty-perl libio-string-perl libip4tc0
libip6tc0 libipc-run-perl libiptc0 libisc-export160 libisc-export169
libisc169 libisccc160 libisl15 libisl19 libisofs6 libjasper1 libjson-c3
libjte1 libjte2 liblinux-epoll-perl liblircclient0 liblist-compare-perl
liblist-moreutils-perl libllvm10 libllvm10:i386 libllvm6.0 liblouis9
liblqr-1-0 liblwres141 libmagickcore-6.q16-6 libmeanwhile1 libminiupnpc10
libmng2 libmodule-implementation-perl libmozjs-52-0 libmpeg2-4 libmpx0
libmpx2 libmutter-2-0 libnet-domain-tld-perl libnet-ip-perl libnetpbm10
libnettle6 libnettle6:i386 libnm-glib-vpn1 libnm-glib4 libnm-gtk0
libnm-util2 libnma-common libnss-myhostname libntfs-3g88
libnumber-compare-perl liboauth0 libopencc1 libopencore-amrwb0 libopenexr22
libpackage-stash-perl libpackage-stash-xs-perl libpackagekit-glib2-16
libpath-tiny-perl libpcre16-3 libperl4-corelibs-perl libpng12-0:i386
libpoppler58 libpoppler73 libprocps4 libprocps6 libprotobuf-c1
libprotobuf-lite10 libprotobuf-lite9v5 libprotobuf10 libpurple-bin
libpurple0 libpython2.7 libpython3.6-minimal libqt5feedback5
libqt5multimedia5 libqt5opengl5 libqt5positioning5 libqt5printsupport5
libqt5webchannel5 libquvi-scripts libraw15 libraw16 libreadline7
libref-util-xs-perl libreoffice-avmedia-backend-gstreamer libreoffice-gtk
libreoffice-gtk2 libreoffice-style-human librhythmbox-core9
librole-tiny-perl librsync1 libsane1 libsereal-decoder-perl
libsereal-encoder-perl libsereal-perl libsidplay1v5
libsignon-plugins-common1 libsignon-qt5-1 libsqlite3-0:i386
libstrictures-perl libstruct-dumb-perl libsub-exporter-progressive-perl
libsub-identify-perl libsuitesparseconfig4.4.6 libswresample2 libtcl8.6
libtest-fatal-perl libtest-refcount-perl libtext-levenshtein-perl libtk8.6
libtype-tiny-perl libtype-tiny-xs-perl libunicode-utf8-perl libusbmuxd4
libvariable-magic-perl libvpx3 libvpx5 libwebkit2gtk-4.0-37-gtk2 libwebp5
libwebpdemux1 libwebpmux1 libwebrtc-audio-processing-0 libwinpr-crt0.1
libwinpr-dsparse0.1 libwinpr-handle0.1 libwinpr-input0.1
libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-registry0.1
libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libx265-146
libx86-1 libxapian22v5 libxfont1 libxtables11 libyaml-libyaml-perl
libzeitgeist-1.0-1 libzephyr4 netpbm nplan patchutils pidgin-data
plainbox-secure-policy pm-utils printer-driver-gutenprint python-asn1crypto
python-fasteners python-monotonic python-ndg-httpsclient python-pil
python-sip python-talloc python-zeitgeist python3-feedparser python3-oauth
python3-padme python3-pyasn1 python3-pycurl python3-pyparsing
python3-soupsieve python3-xlsxwriter python3-zope.interface
python3.6-minimal qml-module-qt-labs-folderlistmodel
qml-module-qtgraphicaleffects qml-module-qtquick-layouts
qml-module-qtquick-window2 qml-module-qtquick2 qml-module-qttest
qml-module-ubuntu-performancemetrics rename signon-plugin-oauth2
suru-icon-theme t1utils tcl tcl8.6 tcpd ubuntu-mobile-icons
ubuntu-web-launchers ubuntuone-client-data unity-lens-files unity-lens-music
unity-lens-video unity-scope-chromiumbookmarks unity-scope-colourlovers
unity-scope-openclipart unity-scope-tomboy unity-scope-video-remote
unity-scope-virtualbox unity-scope-yelp unity-scopes-runner vbetool
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
dfu-util libusb-1.0-0-dev libusb-1.0-doc
The following NEW packages will be installed
dfu-util libusb-1.0-0-dev libusb-1.0-doc
0 to upgrade, 3 to newly install, 0 to remove and 0 not to upgrade.
Need to get 270 kB of archives.
After this operation, 1,938 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu focal/main amd64 libusb-1.0-0-dev amd64 2:1.0.23-2build1 [64.4 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu focal/main amd64 libusb-1.0-doc all 2:1.0.23-2build1 [172 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu focal/universe amd64 dfu-util amd64 0.9-1 [33.1 kB]
Fetched 270 kB in 1s (284 kB/s)
Selecting previously unselected package libusb-1.0-0-dev:amd64.
(Reading database ... 246870 files and directories currently installed.)
Preparing to unpack .../libusb-1.0-0-dev_2%3a1.0.23-2build1_amd64.deb ...
Unpacking libusb-1.0-0-dev:amd64 (2:1.0.23-2build1) ...
Selecting previously unselected package libusb-1.0-doc.
Preparing to unpack .../libusb-1.0-doc_2%3a1.0.23-2build1_all.deb ...
Unpacking libusb-1.0-doc (2:1.0.23-2build1) ...
Selecting previously unselected package dfu-util.
Preparing to unpack .../dfu-util_0.9-1_amd64.deb ...
Unpacking dfu-util (0.9-1) ...
Setting up libusb-1.0-doc (2:1.0.23-2build1) ...
Setting up libusb-1.0-0-dev:amd64 (2:1.0.23-2build1) ...
Setting up dfu-util (0.9-1) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for doc-base (0.10.9) ...
Processing 1 added doc-base file...
0 Kudos
23 Views
brich
Contributor III

Thanks!  Yes you are correct, WSL is missing a critical thing... the ubuntu desktop.  Even though I only needed the command-line versions of the tool installed, there's no way to do that by itself since only one installation executable is provided by NXP.  The solution for me was to get a full blown ubuntu desktop running in WSL, and then installing the tool.  Once installed, the command-line tools can be used without a desktop session.

 

0 Kudos