MCUXpresso does not discover JLink probe

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MCUXpresso does not discover JLink probe

Jump to solution
3,450 Views
guitardenver
Contributor IV

I am using MCUXpresso IDE v10.2.1 [Build 795] [2018-07-25]. I have a SEGGER JLink Ultra+ debug probe.

JLink_V640 Installed on my PC running Windows 10 

Using SEGGER SystemView as well as JLinkRTTViewer works just fine so I know the probe enumerates correctly and the PC can talk to it.

In MCUXpresso, in the "Debug your project" options in the Quickstart panel, I click the JLink Icon and "Debug using SEGGER J-Link probes".

The dialog box shows up and says "No compatible probes available. They may be disabled, disconnected, not powered, already in use or not compatible with this target."

Capture.JPG

Here is the console output:

[Started server]
[Connected on port 3025]
redlink> ProbeList
No probes found
redlink> ProbeList
No probes found
redlink> ProbeList
No probes found
redlink> ProbeStatus
redlink> quit
[Closed]

I have the LPCXpresso546 eval board as well that has a JLink debugger and it does not find that either. My project nor any example SDK project seems to work.

0 Kudos
1 Solution
2,620 Views
lpcxpresso_supp
NXP Employee
NXP Employee

So looking at your screenshot of the IDE Preferences, I can see that for some reason you are pointing at the wrong executable - probably as a result of manually editing the option. You should be pointing at "JLinkGDBServerCL.exe".

On the assumption that v6.40 is the latest SEGGER software install on your machine, and it is in the default location, then the IDE should automatically find the right file and correctly set the preference if you just click on the "Restore Defaults" button at the bottom of the J-Link Options page of the IDE Preferences.

Hopefully you should then be up and running.

Regards,

MCUXpresso IDE Support

View solution in original post

0 Kudos
4 Replies
2,621 Views
lpcxpresso_supp
NXP Employee
NXP Employee

So looking at your screenshot of the IDE Preferences, I can see that for some reason you are pointing at the wrong executable - probably as a result of manually editing the option. You should be pointing at "JLinkGDBServerCL.exe".

On the assumption that v6.40 is the latest SEGGER software install on your machine, and it is in the default location, then the IDE should automatically find the right file and correctly set the preference if you just click on the "Restore Defaults" button at the bottom of the J-Link Options page of the IDE Preferences.

Hopefully you should then be up and running.

Regards,

MCUXpresso IDE Support

0 Kudos
2,621 Views
guitardenver
Contributor IV

You lead me to the answer. In the IDE preferences for the J-Link, the "J-Link server executable" was wrong. It was pointing to the JLink.exe and not the JLinkGDBServerCL.exe. The MCUXpresso users guide Section 4.10.1 shows it as the JLinkGDBServerCL.exe.

Not sure how that happened because I never new that setting existed till you told me, so I didn't change it. It must have changed somehow when I updated to the latest MCUXpresso or the latest JLink_V640?

Below is the correct executable path. And the IDE now finds my JLink probe

pastedImage_1.png

2,621 Views
lpcxpresso_supp
NXP Employee
NXP Employee

The IDE invokes the SEGGER supplied GDBserver to request a list of attached J-Link probes. The information this returns is then parsed by the IDE for display within the probe discovery mechanism. We've certainly never seen any issues similar to what you describe with this process.

Can you confirm the IDE preferences regarding the version of the SEGGER software being used for your workspace? See section 4.10.1, "SEGGER software installation" of the MCUXpresso IDE v10.2.1 User Guide for more details of this.

It would be interesting to know if you continue to see problems if you reselect the version of SEGGER's software that was supplied with MCUXpresso IDE v10.2.1 (v6.32h)

Anyway, if you are continuing to see problems, can you please ZIP up and post the .log file from inside the .metadata folder inside your workspace - this may provide some clues as to what is going wrong.

[Note : the console output you have provided is the one for LinkServer, hence not relevant for J-Link debugging]

Regards,

MCUXpresso IDE Support

0 Kudos
2,621 Views
guitardenver
Contributor IV

Here is my IDE preferences for JLink. 

Capture.JPG

I did confirm that the file does exist
pastedImage_2.png

I downloaded and installed JLink_V632, JLink_V632i, and JLink_V620C. Then tried each one by changing the path to the JLink.exe file in the IDE preferences. All of them did not work and gave the same error of not finding a compatible probe. I have no other programs running that use the JLink probe or GDB.


Attached is the log file for when I tried to discover a probe with the IDE configured to use the JLink_V640.

0 Kudos