J-Link support unavailable

cancel
Showing results for 
Search instead for 
Did you mean: 

J-Link support unavailable

Jump to solution
1,561 Views
Contributor V

I'm making the transition from KDS-2.x to MCUXpresso 10.1.1 and have run into a small snag.  

Short form:

When I try to debug my device, I get an alert:

Screen Shot 2018-03-28 at 11.24.18.png

... and I'm not sure what it wants in the way of a path to the J-Link server.

Details:

My Environment:

  • macOS High Sierra 10.3.3
  • MCUXpresso 10.1.1
  • Segger J-Link GBD Server V6.301
  • USB Connection to J-Link
  • SWD interface to KL27Z64 device

What I've Tried:

  • This setup worked fine in my KDS 2.x setup
  • I can communicate with the device using the SEGGER J-Flash Lite V6.30i app -- it recognizes the device, so I know the connection is good.
  • In MCUXpresso, I installed SDK 2.3.0 and built the canonical "Hello, World" app from the SDK examples.  It compiled without error.
  • In MCUXpresso, I created a new Debug Configuration under GDB Segger Interface Debugging
  • On the Main tab, I verified the Project and C/C++ Application fields.
  • On the Debugger Settings tab:
    • JLink Interface = USB
    • Device = MKL27Z64xxx4 (I had to set that manually)
    • Target Interface = SWD
    • Speed = Auto
    • GDB Server Startup and Port Selection = Auto
    • GDB / SWO / TELNET / Endianness / Disconnect Behavior = [2331, 2332, 2333, little, Run]
    • Power Target = False
    • Enable Semihosting = True

What Happened:

When it first prompted me for a path to the J-Link Server, I clicked on "No", whereupon it failed with the message "Error in final launch sequence: Cannot get Jtag device".

The next time it prompted me, I clicked "Yes" and supplied "/Applications/SEGGER/JLink_V630i/JLinkGDBServer.app" as the path.  Evidently it didn't like that either, since it immediately repeated the same dialog box.

So this time I provided "/Applications/SEGGER/JLink_V630i/JLinkGDBServerCLExe" as the path.  This caused the dialog box to disappear, but the build still failed with "Error in final launch sequence: Cannot get Jtag device".

In Summary

The interface to the J-Link "just worked" in the KDS environment, so I've come to take it for granted.  I'm sure I'm missing some key piece of information in making the transition to MCUXpresso.  (And what are the changes that Erich Styger has already blogged about this?  Probably 95%!  :smileyhappy:  I guess I should go check...)

Tags (1)
1 Solution
52 Views
NXP TechSupport
NXP TechSupport

Hello Robert,

Yes, the green icon can't used on MCUXPresso , please use the blue icon(or the one under Quickstart Panel):

pastedImage_1.png

You can find this information in "MCUXpresso_IDE_User_Guide.pdf":

pastedImage_2.png

Hope it helps


Have a great day,
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
8 Replies
52 Views
NXP Employee
NXP Employee

I also faced the same issue after re-installing my NXP programming tools and your answer helped me a lot. Thanks again :smileywink:

0 Kudos
52 Views
Contributor I

I was looking for the solution to the same problem. Thanks for providing the information. Your post has provided me with the relevant results.

https://newzealand.babasupport.org/ you can check this site if you are looking for something related to it.

0 Kudos
52 Views
NXP Employee
NXP Employee

Yes, we always recommend using one the MCUXpresso IDE debug buttons, generally the one on the Quickstart Panel (rather than the generic, green, Eclipse one). This way the IDE can then automatically discover the debug probe connected to your PC and generate an appropriate debug launch configuration.

Again, for more details please see the MCUXpresso IDE v10.1 User Guide. Or for a quick overview, watch the video at  Video Link : 7772 

Regards,

MCUXpresso IDE Support

0 Kudos
52 Views
NXP Employee
NXP Employee

The issue here is that SEGGER have recently changed the way they deliver the executables in their firmware package on Mac (and Linux) such that the IDE's autodetection of the SEGGER executable no longer functions correctly. If you are using the version of SEGGER delivered with the IDE, then you won't have problems. But if you manually install a recent (v6.3x) version then you will encounter the problem you have seen.

This issue will be resolved in the next IDE release. But you can actually easily fix the problem by manually selecting the JLinkGDBServerCLExe file from within the SEGGER software installation you have installed yourself, via

  • Preferences - MCUXpresso IDE - J Link Options

For more details, please see section 3.8.1, "SEGGER Software Installation" of the MCUXpresso IDE v10.1 User Guide.

PS : As you are using Mac OS High Sierra, I would suggest that you also take a look at this post and potentially install the user supplied patch....

Regards,

MCUXpresso IDE Support

52 Views
Contributor V

As you indicate, the user must select JLinkGDBServerCLExe for the path to the path to the J-Link server.

That is necessary but not sufficient.

The user must also use the blue debug icon and not the green debug icon for things to work.  Not intuitive, but it works!

0 Kudos
52 Views
Contributor V

Update: I got it to work (but I don't know why it worked)...

I quit MCUExpresso, deleted the project directory (and .metadata) and re-created the hello_world demo from scratch. 

This time, instead of clicking on Run => Debug Configurations and adding a new configuration under GDB Segger Interface Debugging, I clicked on the Quickstart Panel's "Debug 'frdmkl27z_demo_apps_hello_world' [Debug]" line.

This time, it put up a modal panel saying that it was discovering SEGGER J-Link probes and also asked for a path to the J-Link Server.  And as before, I gave it a path to JLinkGDBServerCLExe.

This time, it put up a new "Probes Discovered" panel, with the J-Link listed as Available.  I selected it and clicked "OK".  

This time it compiled and entered the debugger without any errors.

Lessons learned:

The only lesson I can draw from this experience is "Use the Quickstart Panel to launch your app."  

But I'd still like to know what was wrong with the first approach.

0 Kudos
53 Views
NXP TechSupport
NXP TechSupport

Hello Robert,

Yes, the green icon can't used on MCUXPresso , please use the blue icon(or the one under Quickstart Panel):

pastedImage_1.png

You can find this information in "MCUXpresso_IDE_User_Guide.pdf":

pastedImage_2.png

Hope it helps


Have a great day,
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
52 Views
Contributor V

Thanks.  I wonder how difficult it would be to disable or hide the green debug button until the real fix comes along...

0 Kudos