How do I get MCUXpresso to ignore the MEX file?

cancel
Showing results for 
Search instead for 
Did you mean: 

How do I get MCUXpresso to ignore the MEX file?

Jump to solution
277 Views
Contributor III

Everytime I startup my project (which was started by using example code), it tells me that the <project>.mex is different from the source file.  And I have to select "use the source" everytime.

It's incredibly annoying to do this over and over again.  I've searched high and low and can't find any doc or other forum posts that talk about this.

Therefore, it must just be me that has this issue... can someone please enlighten me on how to "unhook" the reliance on the MEX file?

Thank you.

-stv

1 Solution
36 Views
Contributor III

This is what I was looking for ... .thank you.

View solution in original post

0 Kudos
5 Replies
36 Views
NXP Employee
NXP Employee

Hi Steve,

the warning says that configuration stored in MEX file in your project is different then a project source files (clock_config.c and pin_mux.c). This is not correct state - basically it is an conflict in the configuration.

If you do not modify the source code, go to the Project Explorer, locate the mex file in the project root and remove the file (right click on the MEX file and select Delete). If you later open Pins or Clocks again, the configuration will be re-created from your source code.

If you do any change in the Pins/Clocks configuration, recommend to use Update Project Code. This function

- allows to review what files will be changed in your project

- allows to review changes in the source code before they are applied

- allows to disable update of any tool, if you have your own changes in the generated code

- updates MEX file and source files at once

Regards

Marek

Regards,
Marek
36 Views
NXP Employee
NXP Employee

Hello Steve,

you can:

a) go to the Pins or Clocks perspective and use the "Update project code" button in the toolbar. This way the code will be re-generated (no change I guess) and the MEX file will be saved too and it should be aligned with the source so it should not complain anymore.

b) rename the "mex" file file extension to e.g. "me~". This way the MEX will not be automatically reloaded after the IDE restart. If you manually launch the Config tools using the popup menus, the MEX file will be re-created with the settings stored in the Pins/Clocks sources - and again, it should be aligned with the code.

Regards,

Libor

0 Kudos
36 Views
Contributor III

Hi Libor,

Thanks for the quick reply.

I think you misunderstood what I was saying.

I want nothing to do with the MEX file.  I don't like it and I no longer need it.

If I tell the config tool to regenerate the code, it will overwrite my clocks_config.c file which I do NOT want it to do. 

Basically, I used the clock config tool to setup my clocks originally so I can get my board running.  Then, once all the requirements came in, I needed to make some more tweaks to my clocks (which was easier to just change the code) so as you can see I no longer have need of any of the clock tools.  So I just want to have MCUXpresso just ignore the mex file.

0 Kudos
36 Views
NXP Employee
NXP Employee

Hello Steve,

the dialog warning cannot be disabled; if the mex configuration is not aligned with configuration stored in the sources, it shows the warning. Form what I read I understand that you are not interested in the tools anymore, so you can

a) rename the "mex" file file extension to e.g. "me~"

b) disable the automatic load of last Config Tools Configuration in the preferences:
pastedImage_1.png

Regards,

Libor

37 Views
Contributor III

This is what I was looking for ... .thank you.

View solution in original post

0 Kudos