How can I convert SDK 2.2 to SDK 2.3 ?

cancel
Showing results for 
Search instead for 
Did you mean: 

How can I convert SDK 2.2 to SDK 2.3 ?

384 Views
daviddelacruz
Contributor II

Hello,

I have MCIM6ULL SDK v2.2 and I just installed latest MCUXpresso IDE v10.1.0 [Build 589] [2017-11-14].

When I import this SDK into IDE, I have some errors and finaly, IDE says : 'Unable to find valid manifest files in SDK ...'

How can I do ?

How can I download previous IDE versions ?

How can I convert SDK from v2.2 to v2.3 ?

David

4 Replies

131 Views
lpcxpresso_supp
NXP Employee
NXP Employee

Sorry, but MCUXpresso IDE only supports development of applications for the Cortex-M based "LPC", "Kinetis" and "i.MX RT" MCUs. Cortex-A based processors such as i.MX6ULL are not supported. Thus the SDK you have downloaded does not contain the data required to install it into the IDE.

Regards,

MCUXpresso IDE Support

0 Kudos

131 Views
daviddelacruz
Contributor II

Hello MCUXpresso IDE support,

Thank you for support.

Ok, but I don’t understand why SDK for i.MX6ULL is named “MCUXpresso SDK for i.MX 6ULL”

Can you tell me what MCUXpresso stand for ?

Regards,

David

De : lpcxpresso_support

Envoyé : mardi 9 janvier 2018 20:19

À : David DE LA CRUZ <David.DELACRUZ@theoris.fr>

Objet : Re: - Re: How can I convert SDK 2.2 to SDK 2.3 ?

NXP Community <https://community.freescale.com/resources/statics/1000/35400-NXP-Community-Email-banner-600x75.jpg>

Re: How can I convert SDK 2.2 to SDK 2.3 ?

reply from LPCX support<https://community.nxp.com/people/lpcxpresso_support?et=watches.email.thread> in MCUXpresso IDE - View the full discussion<https://community.nxp.com/message/975786?commentID=975786&et=watches.email.thread#comment-975786>

0 Kudos

131 Views
jamesbone
NXP TechSupport
NXP TechSupport

Hello David,

You are correct there is an MCUXpresso SDK for the i.MX6ULL,  unfortunately the  MCUXpresso IDE, does not have the tool chain to compile the SDK, you need  support with GCC revision v5-2016-q3 from ARM Embedded.   THe SDK was tested and probed using IAR. We recommend IAR Tools. But it works with MCUExpresso, but you need to download and install the ToolChain Separately

Once you install the SDK, there is docs folder, inside you can find the "Getting Started with MCUXpresso SDK for i.MX6ULL Derivatives" You can follow the steps to compile using IAR.
 


Have a great day,
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

131 Views
daviddelacruz
Contributor II

Hello, thank you for your answer.

Yes, I finally installed IAR Tools and It works fine.

David

De : jamesbone

Envoyé : vendredi 12 janvier 2018 18:59

À : David DE LA CRUZ <David.DELACRUZ@theoris.fr>

Objet : Re: - Re: How can I convert SDK 2.2 to SDK 2.3 ?

NXP Community <https://community.freescale.com/resources/statics/1000/35400-NXP-Community-Email-banner-600x75.jpg>

Re: How can I convert SDK 2.2 to SDK 2.3 ?

reply from jamesbone<https://community.nxp.com/people/jamesbone?et=watches.email.thread> in MCUXpresso IDE - View the full discussion<https://community.nxp.com/message/976921?commentID=976921&et=watches.email.thread#comment-976921>