Debian 10 installation failure

cancel
Showing results for 
Search instead for 
Did you mean: 

Debian 10 installation failure

4,508 Views
tintin77
Contributor II

Debian 10 has been released over the weekend. During installation several missing dependencies are reported. All except one I could resolve. The remaining one is libwebkitgtk-1.0-0. This is no longer available through APT. Is there a workaround/solution?

 

Verifying archive integrity... All good. Uncompressing mcuxpressoide installer 100% Installing... (Reading database ... 160674 files and directories currently installed.) Preparing to unpack JLink_Linux_x86_64.deb ... Removing /opt/SEGGER/JLink ... Unpacking jlink (6.449) over (6.449) ... Setting up jlink (6.449) ... Selecting previously unselected package mcuxpressoide. (Reading database ... 160674 files and directories currently installed.) Preparing to unpack mcuxpressoide-11.0.0_2516.x86_64.deb ... Unpacking mcuxpressoide (11.0.0) ... dpkg: mcuxpressoide: dependency problems, but configuring anyway as you requested: mcuxpressoide depends on libncurses5:i386. mcuxpressoide depends on libwebkitgtk-1.0-0; however: Package libwebkitgtk-1.0-0 is not installed.

 

Tags (1)
8 Replies

1,677 Views
kuruibonny
Contributor III

just download libwebkitgtk-1.0-0 manually and install did that with Ubuntu 19.04  and worked perfectly check it over here

0 Kudos

1,676 Views
tintin77
Contributor II

I get a message that I'm unauthorized to view that blog? 

0 Kudos

1,677 Views
kuruibonny
Contributor III

Seems the moderators are bit lazy they haven't approved yet

1,677 Views
kuruibonny
Contributor III

let me paste over

I think this might be late since I was using Ubuntu 18.04 until recently when I upgraded to latest version 19.04

Tried to install Mcuxpresso IDE I encountered some dependency errors but managed to solved it. I had already replied to question about it but decided #to write main post about it.

This is what I did (installed the dependencies)

(my laptop is 64 bit)

sudo apt install libusb-1.0-0-dev

sudo apt install dfu-util

download  amd64 build of icu 60.1-1 

install the package (open terminal from the file location)

sudo dpkg -i libicu60_60.1-1ubuntu2_amd64.deb

download libjavascriptcoregtk-1.0-0_2.4.11-4

and install

sudo dpkg -i libjavascriptcoregtk-1.0-0_2.4.11-4_amd64.deb

download libwebkitgtk-1.0-0_2.4.11-4

and install

sudo dpkg -i  libwebkitgIDEIDEtk-1.0-0_2.4.11-4_amd64.deb

install IDE(open terminal from file location)

install.....

sudo chmod  +x ./mcuxpressoide-11.0.0_2516.x86_64.deb.bin

sudo ./mcuxpressoide-11.0.0_2516.x86_64.deb.bin

After this you should home and dry  :smileycool:

Screenshot from 2019-07-02 20-29-13.png

Everything worked well.

If you have any problem you can reply to this post.

1,677 Views
cervenka
Contributor II

Thank you for these steps. For future i suggest use sudo apt install instead of sudo dpkg -i.

0 Kudos

1,677 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hi tintin77@gmail.com‌,

Could you try using the next command before installing the MCUXpresso?

apt-get install -y libwebkitgtk-3.0-0

Let me know if this helps you.

Best Regards,

Alexis Andalon

0 Kudos

1,677 Views
tintin77
Contributor II

Alexis, Bonny seems to have a solution by manually installing the obsolete packages. Is NXP planning to remove these dependencies to obsolete packages in one of the upcoming releases? More and more distributions seem to have issues with this (Ubuntu 19.04, Debian 10)...

0 Kudos

1,677 Views
tintin77
Contributor II

Hi Alexis,

No, this package is also not available:

$ sudo apt update Hit:1 http://ftp.be.debian.org/debian buster InRelease Get:2 http://ftp.be.debian.org/debian buster-updates InRelease [46.8 kB] Hit:3 http://security.debian.org/debian-security buster/updates InRelease Fetched 46.8 kB in 0s (133 kB/s)               Reading package lists... Done Building dependency tree        Reading state information... Done All packages are up to date.

$ sudo apt-get install -y libwebkitgtk-3.0-0 Reading package lists... Done Building dependency tree        Reading state information... Done Package libwebkitgtk-3.0-0 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'libwebkitgtk-3.0-0' has no installation candidate

Below the available webkit packages:

$ apt search libwebkit
Sorting... Done
Full Text Search... Done
libwebkit2-sharp-4.0-cil/stable 2.10.9+git20160917-1.1 amd64
  CLI bindings for WebKitGTK+ 4.0 using GObject Introspection

libwebkit2-sharp-4.0-cil-dev/stable 2.10.9+git20160917-1.1 amd64
  CLI bindings for WebKitGTK+ 4.0 using GObject Introspection - development

libwebkit2gtk-4.0-37/stable,now 2.24.2-1 amd64 [installed,automatic]
  Web content engine library for GTK

libwebkit2gtk-4.0-37-gtk2/stable 2.24.2-1 amd64
  Web content engine library for GTK - GTK 2 plugin process

libwebkit2gtk-4.0-dev/stable 2.24.2-1 amd64
  Web content engine library for GTK - development files

libwebkit2gtk-4.0-doc/stable 2.24.2-1 all
  Web content engine library for GTK - documentation

0 Kudos