Connection closed by the GDB server issue, Default MCUXpresso IDE Debug

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Connection closed by the GDB server issue, Default MCUXpresso IDE Debug

4,733 Views
michaeljwilson
Contributor II

Good afternoon all, I have been using the MCUXpresso IDE with no issue on a Windows 10 system however, I recently installed this IDE on a Linux computer (Ubuntu 18.04.3 LTS) and found an interesting issue! At first, I thought it was a simple debug configuration issue, verified debug configuration against the Windows machine nothing too obvious was found. Here is my summary so far:

  • ok - Installed MCUXpresso IDE v11.1.1 [Build 3241] [2020-03-02] on Elementary OS
  • ok - Installed CMake
  • ok - Installed gcc-arm-none-eabi-9-2019-q4-major (to troubleshoot)
  • ok - Installed SDK_2.x_FRDM-KE06Z (2.7.0 Mcuxpresso 303 2019-12-19)
  • ok - Installed PEMicro linux driver for FRDM board (linux_drivers_64bit_58_b181128)
  • ok - added read/write rights to serial connection (ttyACM0 and ttyACM1)
  • Open blinky example from SDK

    Issues -->
  • built project

    19:09:29 **** Incremental Build of configuration Debug for project frdmke06z_led_blinky_1 ****
    make -r -j8 all
    make: Nothing to be done for 'all'.

    19:09:29 Build Finished. 0 errors, 0 warnings. (took 621ms)

  • failed debug using default PEMicro launch setting
    P&E Semihosting Console. Connection closed by the GDB server.
    • debugger console reads "monitor setexceptioncatching 2033
    • monitor selectcore 0
    • Ignoring packet error, continuing...
  • modifying GDB settings with
    ${cross_prefix}gdb${cross_suffix}
    gets a little farther but still fails to initiate the breakpoint and step throug debug mode
  • pastedImage_15.png

I read through Connection closed by the GDB server and Eric's awesome mcuoneclipse tutorials and not having success! I am suspecting a serious GDB configuration issue I am missing here! 

I appreciate anyone's help!

BlackNight‌ 

0 Kudos
Reply
11 Replies

4,434 Views
steven_mcgrath
Contributor II

Hello Michael,

Could you try making a change to the "executable" option in you the "GDB Client Settings" section? The executable you will want is the "arm-non-eabi-gdb.exe". It should be located in your MCUXpresso folder with the following path /ide/tools/bin.

Let me know if this resolves any issues.

Steve

0 Kudos
Reply

4,434 Views
michaeljwilson
Contributor II

Thank you for the suggestion, I tried this:

pastedImage_1.png

changed it to path in /ide/tools/bin and that did not work either. See errors below:

Could not determine GDB version after sending: /home/michael/Downloads/mcuxpresso-ide/pkg/mcuxpresso-ide/usr/local/mcuxpresso-ide/ide/tools/bin/arm-none-eabi-gdb --version, response:

0 Kudos
Reply

4,434 Views
steven_mcgrath
Contributor II

Hi Michael,

I believe you should be in the "Debugger" tab rather than the "GDB Debugger Tab" like how you had in your first screenshot. Revert the changes you made within this tab and refer to my first response and try this again.

Steve

0 Kudos
Reply

4,434 Views
michaeljwilson
Contributor II

Thank you for that note. I went back and changed it only in the debugger tab, the error is the same now.

Initially, this was the same error I got when I first installed the IDE. After installing arm-none-eabi-gdb manually in linux path /usr/bin/ then the GDB version was found. From the looks of this, there are two problems on using IDE on linux, 1) installing the IDE does not link the arm-none-eabi-gdb path properly and 2) the GDB configuration produces a "connection closed due to timeout" error.

pastedImage_1.png

0 Kudos
Reply

4,434 Views
converse
Senior Contributor V

If you let MCUXpresso create the debug configuration for you, all of the settings will be correct. Suggest you delete your existing configurations and let MCUXpresso recreate them for you.

0 Kudos
Reply

4,434 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello Michael,

I have some questions about this:

Is the board working on another PC? It could be the board firmware the one causing the problem.

I'm not familiarized with Elementary but have you tried using other Linux distributions?

Best Regards,

Alexis Andalon

0 Kudos
Reply

4,434 Views
michaeljwilson
Contributor II

Hi Alexis,

thank you for responding. To answer the linux question, I have tried this on Elementary OS, Zorin OS, and also Manjaro Linux versions. In all linux versions, the GDB server is closed and refuses to start the debug session. Using the same board on a Windows 10 computer, the GDB session works normally.

Below is the firmware for the two FRDM-KE06 boards I have:

Board Name is: FRDM-KE06Z
MicroBoot Kernel Version is: 1.05
Bootloader Version is: 1.11
Installed Application: PEMicro FRDM-KE06Z Mass Storage/Debug App
Application Version is: 1.18

Board Name is: FRDM-KE06Z
MicroBoot Kernel Version is: 1.05
Bootloader Version is: 1.10
Installed Application: PEMicro FRDM-KE06Z Mass Storage/Debug App
Application Version is: 1.18

0 Kudos
Reply

4,434 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello Michael,

Only as a test could you try using the segger firmware?

Best Regards,

Alexis Andalon

0 Kudos
Reply

4,434 Views
michaeljwilson
Contributor II

Great Idea Alexis! I have success with debugger using Segger JLink firmware. One caveat though, I still had to manually install GDB in linux path because during IDE install, I think it wasn't linked correctly. See below:

pastedImage_1.png

However, I'm still scratching my head on PEMicro issues. I would say, I can close this post as answered but there is surely another user out there wondering why it doesn't work with default firmware.

Thank you again!

0 Kudos
Reply

4,434 Views
michaeljwilson
Contributor II

Alexis, I'm not familiar with this firmware, do you have a link to share?

0 Kudos
Reply

4,434 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hello Michael,

In the following link, you can find the different firmware that supports the FRDM:

OpenSDA Serial and Debug Adapter | NXP 

Could you try using the Segger JLink? 

Best Regards,

Alexis Andalon

0 Kudos
Reply