Can't run firmware on OM13092 in stand alone

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't run firmware on OM13092 in stand alone

Jump to solution
447 Views
MAPC
Senior Contributor I

I just downloaded gpio driver example to my OM13092 kit. While the Link probe is connected to it, it works fine, but it doesn't work when it runs stand alone. Is there a specific hardware setting to do it like a jumper or something like that?

1 Solution
182 Views
Carlos_Mendoza
NXP Employee
NXP Employee

Hi Marco,

You seem to have semihosting enabled for your project, please try disabling this option to the project properties:

pastedImage_1.png

When you import a project there is an option on the wizard where you chose to enable or disable this option:

pastedImage_2.png


Hope it helps!

Best Regards,
Carlos Mendoza
Technical Support Engineer

View solution in original post

0 Kudos
6 Replies
182 Views
radomirkozub-re
NXP Employee
NXP Employee

Do you download it to RAM or FLASH?

0 Kudos
182 Views
MAPC
Senior Contributor I

I also tried with Flash Programmer, but it didn't work.

0 Kudos
183 Views
Carlos_Mendoza
NXP Employee
NXP Employee

Hi Marco,

You seem to have semihosting enabled for your project, please try disabling this option to the project properties:

pastedImage_1.png

When you import a project there is an option on the wizard where you chose to enable or disable this option:

pastedImage_2.png


Hope it helps!

Best Regards,
Carlos Mendoza
Technical Support Engineer

View solution in original post

0 Kudos
182 Views
MAPC
Senior Contributor I

Hi, Carlos

Correct! It is working perfectly now!

Could you explain me what semihosting is?

Thanks!

0 Kudos
182 Views
anthony_huereca
NXP Employee
NXP Employee

Hi Marco,

  Check out this Community document: https://community.nxp.com/docs/DOC-334074?sr=stream 

-Anthony 

182 Views
MAPC
Senior Contributor I

Hi, Radomir!

Where do identify in MCUXpresso if I'm loading to RAM or Flash?

0 Kudos