After restart MCUXpresso in workspace on CMSIS_DSPLIB_CMx folders appear the ERROR icons.

cancel
Showing results for 
Search instead for 
Did you mean: 

After restart MCUXpresso in workspace on CMSIS_DSPLIB_CMx folders appear the ERROR icons.

Jump to solution
1,270 Views
danielkrol
Contributor III

Hi,

I noticed a problem on OSX. After restart MCUXpresso in workspace on CMSIS_DSPLIB_CMx folders appear the ERROR icons. Projects using the CMSIS_DSPLIB are built normally.
Moreover, every time MCUXpresso starts, it asks whether to accept incoming network connections (LPCXpresso asked only once).

0 Kudos
1 Solution
985 Views
danielkrol
Contributor III

Hi,

Thank you for your reply. I currently working with three MCU: LPC1347, LPC4088 and LPC4357. Unfortunately, none of these MCU is supported by the new SDK (if I'm not wrong?). BTW will you develop the SDK for older MCU like LPC40xx?

The problem with the accept incoming network connections after restart IDE is completely independent of the above.

In conclude I waiting for fix in next release.

Regards,
Daniel

View solution in original post

0 Kudos
3 Replies
986 Views
danielkrol
Contributor III

Hi,

Thank you for your reply. I currently working with three MCU: LPC1347, LPC4088 and LPC4357. Unfortunately, none of these MCU is supported by the new SDK (if I'm not wrong?). BTW will you develop the SDK for older MCU like LPC40xx?

The problem with the accept incoming network connections after restart IDE is completely independent of the above.

In conclude I waiting for fix in next release.

Regards,
Daniel

0 Kudos
985 Views
lpcxpresso_supp
NXP Employee
NXP Employee

Actually, after further discussion we have worked out what you meant - and have replicated the issue with the errors you see against the CMSIS_DSPLIB_CMx folders. This is actually harmless and can be ignored - but we will fix for the next release.

You are seeing this because the SDK part support handling is checking the projects in your workspace as the workspace is loaded and seeing that no MCU matches these projects. But this is a mistake - because these folders are actually just containers - they don't actually build (and hence have no MCU settings).

You can clear the error message / icons on these folders by going to the "Problems" view (in parallel with the "Installed SDKs" and "Console" views), selecting the errors and deleting them.

Regards,

MCUXpresso IDE Support

985 Views
lpcxpresso_supp
NXP Employee
NXP Employee

What MCU are you using?

Note that if you are using a part added to MCUXpresso IDE via an SDK, then you should use CMSIS DSP library that is (optionally) provided as part of the SDK package, not the old CMSIS DSP library that dates back to LPCXpresso IDE (described at - https://community.nxp.com/message/630590 ).

With regards to the incoming network connection message - can you clarify exactly what connection this is for?

Regards,

MCUXpresso IDE Support

0 Kudos