RUNTIME ERROR 216

cancel
Showing results for 
Search instead for 
Did you mean: 

RUNTIME ERROR 216

311 Views
NXP Employee
NXP Employee

Hi

I have a custom board with KL02 and a  P&E Multilink ACP debugger. SWD connections are correct, reset as well. 

I always use this board.

After sometime without use when I started debugging the project the P&E Multilink ACP began updating itself. Since then, whenever I try to debug it shows "Connection closed by the GDB server." and popup  Runtime error 216 at ...

 

I checked early recent related posts and it seems this issue is happening in different platforms with P&E or OpenSDA not long ago.

I tried to remove and install the MCUxpresso and the latest P&E driver back again.

With the Freedom board with OpenSDA everything works fine.

By the way, I can erase or program the Flash. Only debugging is the problem.

 

Closest post I have found is Gdb server closes connection.@Gdb server closes connection. 

Please help.

Thank you

Andre VB

Labels (1)
2 Replies

49 Views
Contributor II

Hi

My FRDM-KE02Z40M had the same Runtime error with frdmke02z40m_led_blinky_1.
I've taken care of the PEmicro Blog, but the Runtime error continues.


FYI: In FRDM-KL25Z, I used the same MCUXpresso IDE with NO Runtimetime error without any solution. I'm able to debag without problems.

My environment is Windows 10 v2004, MCUXpressoIDE_11.1.1, FRDM-KE02Z40M SDK 2.8.0 (2020-07-21), FRDM-KL25Z SDK 2.2.0.

Attached 2 figures are the difference in PEmicro Blog.

Thank you.

0 Kudos

49 Views
NXP TechSupport
NXP TechSupport

Hello Andre Luis Vilas Boas

 

There seems to be an issue between the latest MCUXpresso release and the P&E drivers. MCUXpresso works well with the SEGGER OpenSDA. I suggest you try this IDE configuration http://www.pemicro.com/blog/index.cfm?post_id=130

 

Please let me know if this post solved the problem.

Best regards,

Omar