MCUXpressoIDE vs antivirus

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MCUXpressoIDE vs antivirus

Jump to solution
1,129 Views
Luky
Contributor II

Hello,

I installed new version MCUXpressoIDE_10.2.1_795 and imported SDK to KE02. When I create new project and click to to debug my antivirus (Avast) show potentional problem (IDP.generic) with redlinkserver.exe and pegdbserver_console.exe during searching debug probes and move this file to virus chest. It isnť problem for me becasue I use Segger probe. I´m not sure it is problem of false alarm.

I had similar problem on the previous version of MCUXpressoIDE (maybe one year ago). When I tryed install it to my company laptop, my company antivirus complete delete install file.

Lukas

1 Solution
956 Views
lpcxpresso_supp
NXP Employee
NXP Employee

We see no virus warnings of this type here, though we do not use Avast. And given that MCUXpresso IDE v10.2.1 was released back in July - we would have been flooded by complaints by now if there was a real issue.

Both of the exe's you reference are related to debugging and make use of localhost network connections (though J-Link debug does too). Maybe this could be triggering a firewall related warning in your system.

Regards,

MCUXpresso IDE Support

View solution in original post

2 Replies
957 Views
lpcxpresso_supp
NXP Employee
NXP Employee

We see no virus warnings of this type here, though we do not use Avast. And given that MCUXpresso IDE v10.2.1 was released back in July - we would have been flooded by complaints by now if there was a real issue.

Both of the exe's you reference are related to debugging and make use of localhost network connections (though J-Link debug does too). Maybe this could be triggering a firewall related warning in your system.

Regards,

MCUXpresso IDE Support

956 Views
Luky
Contributor II

Thank you for your response

0 Kudos