MCUXpresso FreeRTOS aware issues

cancel
Showing results for 
Search instead for 
Did you mean: 

MCUXpresso FreeRTOS aware issues

90 Views
Contributor I

I am hoping someone can shed some light on issues I am having getting the FreeRTOS aware features of MCUExpresso to work reliably.  I have seen the different guides and discussions regarding making sure that the project is configured correctly for the IDE to be RTOS aware and thought I was following everything correctly.  I am using the GNU tool chain and the Linkserver OpenSDA debug interface.  Optimization is set to 0.  FreeRTOS TAD memory read timeout is increased to 40,000 mS.  I saw this with MCUXpresso ver11.1 (for Windows) and have the same issues after upgrading to 11.2 and importing the same project.  I am working with the latest download of FreeRTOS+TCP.  HW target is iMX.RT1064 EVK.

At times I can pause my target and the IDE correctly displays the RTOS task details.  Immediately after installing 11.2 and rebuilding it worked correctly.  Then when I rebuilt and reloaded with no code changes and tried again it reported it couldn't find RTOS info as shown below (bottom right).  Odd thing to me is that in the debug window (top left) it is displaying the details for the 4 tasks so it appears the it is somewhat aware.  .

Any assistance is appreciated.

Dave

pastedImage_2.png

Log files...

MCUXpresso IDE RedlinkMulti Driver v11.1 (Jul 7 2020 10:48:32 - crt_emu_cm_redlink build 5)
Found chip XML file in C:/Users/marselld/Documents/MCUXpressoIDE_11.1.1_3241/workspace/MIMXRT1064_FreeRTOS_enet_drivers/Debug\MIMXRT1064xxxxA.xml
( 5) Remote configuration complete
Reconnected to existing LinkServer process.
============= SCRIPT: RT1064_connect.scp =============
RT1064 Connect Script
DpID = 0BD11477
APID = 0x04770041
Disabling MPU
Configure FlexRAM for 768KB OC RAM, 128KB I-TCM, 128KB D-TCM
Finished
============= END SCRIPT =============================
Probe Firmware: DAPLink CMSIS-DAP (ARM)
Serial Number: 02320000141286c200000000000000000000000097969905
VID:PID: 0D28:0204
USB Path: \\?\hid#vid_0d28&pid_0204&mi_03#7&3a5b60ad&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Using memory from core 0 after searching for a good core
debug interface type = Cortex-M7 (DAP DP ID 0BD11477) over SWD TAP 0
processor type = Cortex-M7 (CPU ID 00000C27) on DAP AP 0
number of h/w breakpoints = 8
number of flash patches = 0
number of h/w watchpoints = 4
Probe(0): Connected&Reset. DpID: 0BD11477. CpuID: 00000C27. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Content of CoreSight Debug ROM(s):
RBASE E00FD000: CID B105100D PID 000008E88C ROM (type 0x1)
ROM 1 E00FE000: CID B105100D PID 04000BB4C8 ROM (type 0x1)
ROM 2 E00FF000: CID B105100D PID 04000BB4C7 ROM (type 0x1)
ROM 3 E000E000: CID B105E00D PID 04000BB00C Gen SCS (type 0x0)
ROM 3 E0001000: CID B105E00D PID 04000BB002 Gen DWT (type 0x0)
ROM 3 E0002000: CID B105E00D PID 04000BB00E Gen (type 0x0)
ROM 3 E0000000: CID B105E00D PID 04000BB001 Gen ITM (type 0x0)
ROM 2 E0041000: CID B105900D PID 04001BB975 CSt ARM ETMv4.0 type 0x13 Trace Source - Core
ROM 2 E0042000: CID B105900D PID 04004BB906 CSt type 0x14 Debug Control - Trigger, e.g. ECT
ROM 1 E0040000: CID B105900D PID 04000BB9A9 CSt type 0x11 Trace Sink - TPIU
ROM 1 E0043000: CID B105F00D PID 04001BB101 Sys (type 0x0)
NXP: MIMXRT1064xxxxA
DAP stride is 1024 bytes (256 words)
Inspected v.2 External Flash Device on SPI using SFDP JEDEC ID MIMXRT1064.cfx
Image 'iMXRT1064_SFDP_QSPI Jul 7 2020 10:54:42'
Opening flash driver MIMXRT1064.cfx
Sending VECTRESET to run flash driver
Flash variant 'RT1064' detected (4MB = 64*64K at 0x70000000)
Closing flash driver MIMXRT1064.cfx
Connected: was_reset=false. was_stopped=true
Awaiting telnet connection to port 3330 ...
GDB nonstop mode disabled (using allstop mode)
FreeRTOS stack backtrace is enabled
Opening flash driver MIMXRT1064.cfx (already resident)
Sending VECTRESET to run flash driver
Flash variant 'RT1064' detected (4MB = 64*64K at 0x70000000)
Writing 76756 bytes to address 0x70000000 in Flash
Sectors written: 0, unchanged: 2, total: 2
Erased/Wrote sector 0-1 with 76756 bytes in 22msec
Closing flash driver MIMXRT1064.cfx
Flash Write Done
Flash Program Summary: 76756 bytes in 0.02 seconds (3407.14 KB/sec)
Starting execution using system reset and halt target
Stopped (Was Reset) [Reset from Unknown]
Stopped: Breakpoint #1
Stopped: Halt
Labels (1)
0 Kudos
1 Reply

21 Views
Senior Contributor II

Could you share the gdb traces/log (see Board Bring-Up Tips, GDB Logs and Traces in Eclipse | MCU on Eclipse ) too?

0 Kudos