MCUX 11.0.0 - Indexer can't find standard includes

cancel
Showing results for 
Search instead for 
Did you mean: 

MCUX 11.0.0 - Indexer can't find standard includes

Jump to solution
183 Views
Senior Contributor I

So, this seems to be a re-hash of my previous issue (MCUX 10.3.1 - How to fix not finding standard header files?), but it's not happening consistently.  Right now my coworker and I are working on a C++ project using MCUX 11.0.0 (which we can now debug with thanks to turning off the Live Variables service).  Everything seems OK with the IDE on my machine.  But on his machine, the C and C++ includes aren't resolving:

mcux_11.0.0_c_includes_not_found.png

mcux_11.0.0_cpp_includes_not_found.png

It was my understanding that MCUX 11.0.0 was supposed to fix the issue with the source indexer.  I had thought that the issue was fixed because everything seemed fine on my machine with 11.0.0 (the indexer was broken for me in 10.3.x).  But on my coworkers machine, the indexer is broken in 11.0.0.

Interestingly, on both of our machines, the "Paths and Symbols" configuration does not list the standard include paths:

mcux_11.0.0_paths_and_symbols_cpp.png

(The "GNU C" paths are identical to the C++ paths.)  So the indexer works fine on my system, but it doesn't work on his.  How do I fix this?

David R.

1 Solution
46 Views
NXP Employee
NXP Employee

Hi David,

did you already apply the 'Fixup Parsers' on your project?

pastedImage_1.png

I hope this helps,

Erich

View solution in original post

3 Replies
47 Views
NXP Employee
NXP Employee

Hi David,

did you already apply the 'Fixup Parsers' on your project?

pastedImage_1.png

I hope this helps,

Erich

View solution in original post

46 Views
Senior Contributor I

Well hey, that's a new thing.  Yes, that did in fact clean up the issues with my coworker's machine.  Thanks.

0 Kudos
46 Views
NXP Employee
NXP Employee

Yes, that option is new and has been introduced with V11.0.0 of the IDE.