LPC55S69 eval Board :SPI dma example Failed to transfer buffer !

cancel
Showing results for 
Search instead for 
Did you mean: 

LPC55S69 eval Board :SPI dma example Failed to transfer buffer !

427 Views
sinda
Contributor I

Hi,

I'm testing SPI on new eval board LPC55S69, I'm trying to set this board as master with an external device , no one of examples provided by the SDK succeed to work ! is that related to peripheral tool which is not provided for this Device, or what?

 I'm using SPI7 with pins mentioned in photo attached , connected to  an external device set as slave! 

there is always error in SPI transfer like console photo shows !

0 Kudos
3 Replies

310 Views
sinda
Contributor I

Hi Sabina

I'm using the last SDK 2.6.2, I have two eval boards LPC55S69, I set one as slave with demo example (lpcxpresso55s69_spi_dma_b2b_transfer_slave) and the other one as a master with lpcxpresso55s69_spi_dma_b2b_transfer_master example, I ran the slave before then the master and the transfer fail as the console shows, I did not change anythings on both codes!

0 Kudos

310 Views
Sabina_Bruce
NXP Employee
NXP Employee

Hello,

I've ran the examples without any modifications and had no problems.

Can you please check that the configuration of your connections are correct as shown in the readme file.

pastedImage_1.png

My results:

pastedImage_3.png

Best Regards,

Sabina

0 Kudos

310 Views
Sabina_Bruce
NXP Employee
NXP Employee

Hello,

I'll be happy to help you in figuring out what is going on with your SPI communication. First can you please provide the SDK version you are using. Also can you provide the changes you made to the example to work with the SPI7, so I can try to reproduce the same error from my end.

Best Regards,

Sabina

0 Kudos