LPC54016JET100 Usart config problem

cancel
Showing results for 
Search instead for 
Did you mean: 

LPC54016JET100 Usart config problem

109 Views
Contributor I

In our circuit diagram, PIN0_2 and PIN0_3 are used as serial ports. PIN0_2  and PIN0_3  are configured as USART3.But can not output messages.What should I pay attention to when configuring as usart3.Thanks.

Labels (1)
0 Kudos
2 Replies

6 Views
NXP TechSupport
NXP TechSupport

Hello, 爱飞 张 

In this image, you can find the initial configuration of the usart according to the user manual. Please make sure that the pin mux is the correct one, refer to table 239 of the same user manual. LPC540XX Family of Microcontrollers (MCUs) | NXP 

pastedImage_2.png

I suggest referring the SDK examples to config your usart along with examples to transmit messages. https://mcuxpresso.nxp.com/en/welcome

 

Let me know if this is helpful.

Best regards,

Omar

0 Kudos

6 Views
Contributor I

Hi Omar:

Thanks!

B/R

Aifei Zhang

发件人: nxf54944

发送时间: 2019年12月6日 5:09

收件人: Aifei Zhang

主题: Re: - Re: LPC54016JET100 Usart config problem

NXP Community <https://community.freescale.com/resources/statics/1000/35400-NXP-Community-Email-banner-600x75.jpg>

Re: LPC54016JET100 Usart config problem

reply from Omar Anguiano <https://community.nxp.com/people/nxf54944?et=watches.email.thread> in MCUXpresso Software and Tools - View the full discussion <https://community.nxp.com/message/1242113?commentID=1242113&et=watches.email.thread#comment-1242113>

0 Kudos