FRDM-KW36 Wire ACK Fault in DAP access

cancel
Showing results for 
Search instead for 
Did you mean: 

FRDM-KW36 Wire ACK Fault in DAP access

974 Views
rico1
Contributor I

Hi,

I've did some programming on the FRDM-KW36 board. It wasn't really going as planned... Flashing worked fine though. I tried to upload a hello world example sketch to verify that the board was working. I got a error message with the workspace directory so I temporary made a new workspace2 directory, build the example and tried to program but I got a error message... This has been there and I can't do anything now....

Console log:


Executing flash operation 'Program' (Program file into flash: frdmkw36_driver_examples_flexcan_loopback.axf) - Thu Feb 14 17:08:17 CET 2019
Checking MCU info...
Scanning for targets...
Executing flash action...
MCUXpresso IDE RedlinkMulti Driver v10.3 (Nov 28 2018 02:33:57 - crt_emu_cm_redlink.exe build 748)
( 0) Reading remote configuration
Wc(03). No cache support.
Found part description in XML file MKW36Z4_internal.xml
( 5) Remote configuration complete
Reconnected to existing link server
Connecting to probe 1 core 0 (using server started externally) gave 'OK'
============= SCRIPT: kinetisconnect.scp =============
Kinetis Connect Script
Connecting to Probe Index = 1
This probe = 1
This TAP = 0
This core = 0
DpID = 0BC11477
Assert NRESET
Reset pin state: 00
Power up Debug
MDM-AP APID: 0x001C0020
MDM-AP System Reset/Hold Reset/Debug Request
MDM-AP Control: 0x00000008
MDM-AP Status (Flash Ready) : 0x00000036
Part is secured
Mass Erase Required
============= END SCRIPT =============================
Probe Firmware: DAPLink CMSIS-DAP (ARM)
Serial Number: 0251000041114e45004b3007bcfe000615d1000097969900
VID:PID: 0D28:0204
USB Path: \\?\hid#vid_0d28&pid_0204&mi_03#8&2502162e&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Using memory from core 0 after searching for a good core
connection failed - Nn(05). Wire ACK Fault in DAP access.. Retrying
Using memory from core 0 after searching for a good core
Failed on connect: Nn(05). Wire ACK Fault in DAP access
Connected&Reset. Was: NotConnected. DpID: 00000000. CpuID: 00000000. Info: <None>
Last stub error 0: OK
Last sticky error: 0x0 AIndex: 0
Debug bus selected: MemAp 0
DAP Speed test unexecuted or failed
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
(100) Target Connection Failed
error closing down debug session - Nn(05). Wire ACK Fault in DAP access
Unable to perform operation!
Command failed with exit code 1

Kind regards,

Labels (1)
0 Kudos
6 Replies

67 Views
tufantakak
Contributor II

having the same problem.I am trying to flah a custom board through a frdm-kw36 board with no success.any ideas?

0 Kudos

394 Views
bjemt
Contributor III

I found the problem was that the MCU was locked, It's a simple way of unlocking a MCU in MCUXpresso that I thought I'd share with other novices so they can get going again easily:

 

Unlock Kinetis MCU!!.png

 

Step 1: Open the GUI Flash tool

Step 2: Choose Resurrect locked...

Step 3: Hit Run.

 

In a moment the MCU will be unlocked and ready for more programming action!

394 Views
rico1
Contributor I

Hi,

Tried it but didn't work...

I installed the J-link firmware and everything worked. It gave a message about some security readout function 0x400 I think. I could overwrite this and I re-flashed the DAP firmware and it worked... So there was some protection enabled.

So if anyone experieces these problems maybe this will help ;-)


0 Kudos

394 Views
bjemt
Contributor III

you said :"re-flashed the DAP firmware"  you meen re-flashed OpenSDA version / bootloader or DAPLink firmware application ?

0 Kudos

394 Views
estephania_mart
NXP TechSupport
NXP TechSupport

Hello, 

Maybe next time you can try to use the command "unlock kinetis" in the J-link commander to check if that works for you. 

Regards, 
Estephania 

0 Kudos

394 Views
estephania_mart
NXP TechSupport
NXP TechSupport

Hello, 


Just to confirm, you are using the MCUXpresso, is that correct? Also, I believe you are using the MCUXpresso version 1.3, is that correct?

If you are, could you please try downgrading a version of the tool? 

Regards, 

Estephania 

0 Kudos