Build issues in the default project for MK12dn512 SDK

cancel
Showing results for 
Search instead for 
Did you mean: 

Build issues in the default project for MK12dn512 SDK

252 Views
DeepakKukreja
Contributor III

Hi,

My default project (created using the New project wizard for MCUXpresso IDE) fails to build successfully.

I started with creating a project for MK12DN512VLK5 device using the latest MCUXpresso IDE and followed the steps mentioned in the MCUXpresso user's guide. Downloaded the SDK from the IDE itself, used the new project wizard to create the project and then did a build.

The code compiled successfully but there were several linker errors like below, I guess I am missing something very basic, some incorrect configuration, has someone else faced a similar issue:

c:/nxp/mcuxpressoide_11.1.1_3241/ide/plugins/com.nxp.mcuxpresso.tools.win32_11.1.0.202001081728/tools/bin/../lib/gcc/arm-none-eabi/8.3.1/../../../../arm-none-eabi/bin/ld.exe: error: c:/nxp/mcuxpressoide_11.1.1_3241/ide/plugins/com.nxp.mcuxpresso.tools.win32_11.1.0.202001081728/tools/bin/../lib/gcc/arm-none-eabi/8.3.1/../../../../arm-none-eabi/lib/thumb/v7e-m+fp/hard\libcr_semihost_nf.a(_cr__main.o) uses VFP register arguments, HeadBoard_cortexM4.axf does not

I have attached the complete build log

2 Replies

168 Views
danielchen
NXP TechSupport
NXP TechSupport

Hi Deepak:

I just downloaded the latest SDK from NXP webpage: SDK_2.3.1_MK12DN512XXX5, and use project wizard created a very basic demo, it can build successfully on my side. Please see below pictures.

pastedImage_1.png

What else I need to do to reproduce your issue on my side?

Regards

Daniel

168 Views
DeepakKukreja
Contributor III

Hi Daniel, 

Thanks for checking this out.

I too deleted the project and created a new one which got built fine. I guess must have been some setting but I am not sure.

Thanks

Deepak

0 Kudos