MCUXpresso 11.3 SAI driver update

cancel
Showing results for 
Search instead for 
Did you mean: 

MCUXpresso 11.3 SAI driver update

Jump to solution
84 Views
baldurthorgilss
Contributor III

Hi

I'm trying to connect a I2S microphone to KL46Z256 via SAI and am new to SAI and I2S.

I'm using MCUXpresso 11.3 with SDK 2.4.1 ( I think these are the newest at this time)

I start with a empty project and add I2S to it.   get an warning saying that I need to update my SAI driver from 2.1.14 to 2.1.17 as in the following image.

baldurthorgilss_0-1615759740600.png

The errors at lines 146-148 in the code supports this statement, I guess the newer driver has more definitions in the sai_config_t struct.

I have tried numerous things to update the driver without luck. I have looked for solutions on this forums also without luck. Some similar problems has been solved by some supplied patches that obviously are not a part of an update for the SDK and are specific to other problems. I am out of ideas of what to try and would be happy for any help or comment.

How are drivers updated, specify the SAI driver?

(I'm not even sure that I am on the right track to my goal)

From one post I understood that going to ConfigTools|Data Manager should solve a similar issue. I have tried this with no luck. If this is the way, I guess I need more concrete steps to perform the update. Selecting outdated boards and update/download still leave me with my same old driver version 2.1.14

baldurthorgilss_1-1615760601734.png

 

Best regards,

Baldur

 

 

0 Kudos
1 Solution
67 Views
Petr_H
NXP Employee
NXP Employee

Hi,

In the Peripherals too that you are using, the there is possible to add also older version of the configuration (UI) component that generates code from the older version of the driver.

You need to remove the older version of the configuration component instance using the context menu 'Remove'.

Then, when you click on the I2S0 peripheral in the Peripherals view the component addition dialog is shown (filtering suitable components for the I2S peripheral).

You need to uncheck the "Show only latest component versions": 

Petr_H_0-1615882542977.png

Unfortunately, we don't show the lower SDK version number (2.1.14) as normally these versions should be compatible. However, these components represent different versions 2.1.4 and 2.1.7. Try selecting the first one.

In the components view tooltip, you can see the exact version reference:

Petr_H_1-1615883106724.png

Please let us know if it helps.

best regards

Petr Hradsky

Config Tools Team

 

View solution in original post

0 Kudos
2 Replies
68 Views
Petr_H
NXP Employee
NXP Employee

Hi,

In the Peripherals too that you are using, the there is possible to add also older version of the configuration (UI) component that generates code from the older version of the driver.

You need to remove the older version of the configuration component instance using the context menu 'Remove'.

Then, when you click on the I2S0 peripheral in the Peripherals view the component addition dialog is shown (filtering suitable components for the I2S peripheral).

You need to uncheck the "Show only latest component versions": 

Petr_H_0-1615882542977.png

Unfortunately, we don't show the lower SDK version number (2.1.14) as normally these versions should be compatible. However, these components represent different versions 2.1.4 and 2.1.7. Try selecting the first one.

In the components view tooltip, you can see the exact version reference:

Petr_H_1-1615883106724.png

Please let us know if it helps.

best regards

Petr Hradsky

Config Tools Team

 

View solution in original post

0 Kudos
61 Views
baldurthorgilss
Contributor III

Hi Petr

Thank you so much for a quick and accurate reply, this fixed my problem so now I can continue (after over a week stop)

Baldur

0 Kudos