MCUXpresso 11.3, K32L3 SDK 2.9.0

cancel
Showing results for 
Search instead for 
Did you mean: 

MCUXpresso 11.3, K32L3 SDK 2.9.0

70 Views
aaronhusz
Contributor I

Hello,

I have tried build the frdmk32l3a6_lpi2c_polling_b2b_master_cm4 example project in MCUXpresso 11.3 (Linux) with SDK_2.9.0_FRDM-K32L3A6.zip. I receive the following warning in configtools regarding the use of the LPI2C driver:

Issue: Unsupported version of the LPI2C Driver in the toolchain/IDE project. Required: 2.1.5, actual: 2.2.0. Project might not compile correctly.
Level: Warning
Type: Validation
Tool: Toolchain/IDE project
Origin: Peripherals
Target: Toolchain/IDE project: cm4
Resource: platform.drivers.lpi2c

 

Why would the example from the SDK require a version of the LPI2C driver which was not included in the SDK? Is there a workaround for this so that there is no warning with the 2.9.0 SDK?

 

Thank you,

Aaron

0 Kudos
1 Reply

56 Views
jingpan
NXP TechSupport
NXP TechSupport

Hi aaronhusz,

You can ignore this warning. 

 

Regards,

Jing

0 Kudos